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Input, Output, and
Conversions

Learn how to import and export videos, and perform color space and video
image conversions.

¢ “File Opening, Loading and Saving” on page 1-2

e “Colorspace Formatting and Conversions” on page 1-23

e “Data Formats” on page 1-54
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File Opening, Loading and Saving

In this section...

“Import from Video Files” on page 1-2

“Export to Video Files” on page 1-4

“Batch Process Image Files” on page 1-7

“Partition Video Frames to Multiple Image Files” on page 1-12

“Combine Video and Audio Streams into a Single Video File” on page 1-19
“Import MATLAB Workspace Variables” on page 1-20

“Import a Live Video Stream” on page 1-21

Import from Video Files

In this example, you use the From Multimedia File block to import a video
stream into a Simulink® model and the To Video Display block to view it. This
procedure assumes you are working on a Windows platform:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

From Multimedia File | Computer Vision 1
System Toolbox™ >
Sources

To Video Display Computer Vision 1
System Toolbox >
Sinks

2 Locate a multimedia file that you want to import into Simulink. If you
do not have access to a multimedia file, the Computer Vision System
Toolbox software has sample multimedia files you can use to complete
this procedure.

3 Use the From Multimedia File block to import the multimedia file into the
model. Double-click the From Multimedia File block:



File Opening, loading and Saving

¢ If you do not have your own multimedia file, enter vipmen.avi for the
File name parameter.

e If the multimedia file is on your MATLAB® path, enter the filename for
the File name parameter.

e If the file is not on your MATLAB path, use the Browse button to locate
the multimedia file.

* Set the Image signal parameter to Separate color signals.

By default, the Number of times to play file parameter is set to inf. The
model continues to play the file until the simulation stops.

4 Use the To Video Display block to view the multimedia file. Set the Image
signal parameter to Separate color signals.

5 Connect the blocks so your model looks similar to the following figure.

_ioix
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6 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. On
the Solver pane, set the parameters as follows:

® Stop time = 20
* Type = Fixed-step

e Solver =Discrete (no continuous states)

7 Run your model.
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View your video in the To Video Display window that automatically
appears when you start your simulation.

™ To videoDisHINI=IIY

Note The video that is displayed in the To Video Display window runs at
the frame rate that corresponds to the input sample time. To run the video
as fast as Simulink processes the video frames, use the Video Viewer block.

You have now imported and displayed a multimedia file in your Simulink
model. In “Export to Video Files” on page 1-4, you manipulate your video
stream and export it to a multimedia file. For more information on the blocks
used in this example, see the From Multimedia File and To Video Display
block reference pages. To listen to audio associated with an AVI file, use the
To Audio Device block in DSP System Toolbox™ software.

Export to Video Files

The Computer Vision System Toolbox blocks enable you to export video data
from your Simulink model. In this section, you use the To Multimedia File
block to export an multimedia file from your model.

1 If the model you created in “Import from Video Files” on page 1-2 is not
open on your desktop, you can open an equivalent model. To open the
equivalent model, type the following at the MATLAB command prompt:

ex_import_mmf
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2 Click-and-drag the following blocks into your model.

Block Library Quantity
To Multimedia File Computer Vision 1

System Toolbox >

Sinks
Gain Simulink > Math 3

Operations

3 Use the Gain blocks to increase the red, green, and blue values of the video
stream. This increases the contrast of the video. Set the block parameters

as follows:

¢ Main pane, Gain = 1.2

¢ Signal Attributes pane, Output data type = Inherit: Same as

input

4 Use the To Multimedia File block to export the video to a multimedia file.
Set the block parameters as follows:

¢ Output file name = my_output.avi

® Write = Video only

¢ Image signal = Separate color signals
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5 Connect the blocks as shown in the following figure. You might need to
resize some blocks to do so. Or, for a completed model type the following on
the MATLAB command line:

ex_export_to_mmf
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You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

6 If you have not already done so, set the configuration parameters. Open the
Configuration dialog box by selecting Configuration Parameters from
the Simulation menu. On the Solver pane, set the parameters as follows:

e Stop time = 20
* Type = Fixed-step

e Solver =Discrete (no continuous states)

7 Run your model.
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You can view your video in the To Video Display window. By increasing the
red, green, and blue color values, you increased the contrast of the video.
The To Multimedia File block exports the video data from the Simulink
model to a multimedia file that it creates in your current folder.

" To video Disp R [=TE]

B ®

You have now manipulated your video stream and exported it from a Simulink
model to a multimedia file. For more information, see the To Multimedia File
block reference page.

Batch Process Image Files

A common image processing task is to apply an image processing algorithm
to a series of files. In this example, you import a sequence of images from
a folder into the MATLAB workspace and display the sequence using the
Computer Vision System Toolbox software.

Note In this example, the image files are a set of 10 microscope images of rat
prostate cancer cells. These files are only the first 10 of 100 images acquired.

1 Specify the folder containing the images, and use this information to create
a list of the file names, as follows:

fileFolder = fullfile(matlabroot, 'toolbox',

‘images', 'imdemos');

dirOutput = dir(fullfile(fileFolder,'AT3_1m4_*.tif'));
fileNames = {dirQutput.name}'
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2 View one of the images, using the following command sequence:

I = imread(fileNames{1});
imshow(I);
text(size(I,2),size(I,1)+15,
'Image files courtesy of Alan Partin',
'FontSize',7, 'HorizontalAlignment', 'right');
text(size(I,2),size(I,1)+25,
'dohns Hopkins University',
'FontSize',7, 'HorizontalAlignment', 'right');

e =lolx|

File Edit View Insert Tools Deskiop ‘Window Help

DeEES Kb aadme @ 08|80

Irrage files courtesy of Alan Partin
Jobrs Hopkins Lniversity
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3 Use a for loop to create a variable that stores the entire image sequence.
You are going to use this variable to import the sequence into Simulink.

for i = 1:1length(fileNames)
my_video(:,:,i) = imread(fileNames{i});
end

4 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

Video From Workspace | Computer Vision 1
System Toolbox >
Sources

Video Viewer Computer Vision 1
System Toolbox >
Sinks

5 Connect the blocks so your model looks similar to the following figure.

-0l
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6 Use the Video From Workspace block to import the image sequence into
Simulink. Set the Signal parameter to my_video.

7 Use the Video Viewer block to view the image sequence. Accept the default
parameters.
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8 Set the configuration parameters. Open the Configuration dialog box by
selecting Simulation > Configuration Parameters. On the Solver
pane, set the parameters as follows:

e Stop time = 10
e Type = Fixed-step

e Solver =Discrete (no continuous states)

Because the Video From Workspace block’s Sample time parameter is set
to 1 and the Stop time parameter is set to 10, the Video Viewer block
displays 10 images before the simulation stops.

9 Run your model. You can view the image sequence in the Video Viewer
window.

1-10
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i

File Tools WView Playback Help a
S
C R =i ica

Reacly |: 480640 T=10.000

For more information on the blocks used in this example, see the Video
From Workspace and Video Viewer block reference pages. For additional
information about batch processing, see the Batch Processing Image Files
Using Distributed Computing demo in Image Processing Toolbox. You can
run this demo by typing ipexbatch at the MATLAB command prompt.
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Partition Video Frames to Multiple Image Files

In this section, you use To Multimedia File and Enabled Subsystem blocks to
save portions of one AVI file to three separate AVI files.

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity
From Multimedia File | Computer Vision System Toolbox | 1

> Sources
Insert Text Computer Vision System Toolbox | 1

> Text & Graphics

Enabled Subsystem Simulink > Ports & Subsystems 3

To Multimedia File Computer Vision System Toolbox
> Sinks

Counter DSP System Toolbox > Signal 1
Management > Switches and
Counters

Compare To Constant | Simulink > Logic and Bit 5
Operations

Logical Operator Simulink > Logic and Bit 1
Operations

Stop Simulation Simulink > Sinks 1

2 Place the blocks so that your model looks similar to the one in the following
figure.
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3 Use the From Multimedia File block to import an AVI file into your model.

Set the parameters as follows:

¢ Uncheck Inherit sample time from file checkbox

® Set Desired sample time parameter = 1/30

4 Use the Insert Text block to annotate the video stream with the frame
numbers. Set the parameters as follows:

e Text = 'Frame %d'
* Location=[10 10]
e Color=1[0 1 0]
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The block writes the frame number in green in the upper-left corner of the
output video stream.

5 Double-click each Enabled Subsystem block, and click-and-drag one of the
To Multimedia File blocks into it.

6 Inside each Enabled Subsystem, connect the blocks so that your subsystem
looks similar to the one in the following figure.

5] untitled /Enabled Subsystem * =10 x|
File Edit Wiew Simulation Formak  Tools  Help

NEEHE 2 (e ae

Enable

(1 F———{Image

In1 output.aoi

Audia

To hiuktiredia Filke

FlioDw | | |ode45 w

7 Use the To Multimedia File blocks to send the video stream to three
separate AVI files. Set the block parameters as follows:

¢ Output file name = outputi.avi, output2.avi, and output3.avi,
respectively

® Write = Video only

Each enabled subsystem should now look similar to the subsystem shown
in the following figure.
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8 Use the Counter block to count the number of video frames. You use this
information to specify which frames are sent to which file. Set the block
parameters as follows:

¢ Count event = Free running

¢ Initial count = 1

® OQutput = Count

® (Clear the Reset input check box.
* Sample time = 1/30

® Count data type = uint16

9 Use the Compare to Constant block to send frames 1 to 9 to the first AVI
file. Set the block parameters as follows:

¢ Operator = <

¢ Constant value = 10

1-15



1 Input, Output, and Conversions

10 Use the Compare to Constantl and Compare to Constant2 blocks to send
frames 10 to 19 to the second AVI file. Set the Compare to Constantl block
parameters as follows:

e Operator = >=

* Constant value = 10

Set the Compare to Constant2 block parameters as follows:
¢ Operator = <

e Constant value = 20

11 Use the Compare to Constant3 block to send frames 20 to 30 to the third
AVI file. Set the block parameters as follows:

¢ Operator = >=

¢ Constant value = 20

12 Use the Compare to Constant4 block to stop the simulation when the video
reaches frame 30. Set the block parameters as follows:

e Operator = ==
* Constant value = 30

¢ Qutput data type mode = boolean

13 Connect the blocks so that your model resembles the one in the following
figure.
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14 Set the configuration parameters. Open the Configuration dialog box by
selecting Simulation > Configuration Parameters. Set the parameters
as follows:

® Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)
15 Run your model.

The model saves the three output AVI files in your current folder.
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16 View the resulting files by typing the following commands at the MATLAB
command prompt:

mplay outputi.avi
mplay output2.avi
mplay output3.avi

Then, press the Play button on the MPlay GUI.

. MPlay [3] - File: output3.avi - O] x|

File Tools Wew Playback Help
0 ﬁrﬁ@||ﬂ|@l@{{“§' 100%

MHwa m oo e

Stopped |RGE:1 20160 [100% (30 fps) 11711

You have now sent portions of an AVI file to three separate AVI files using
an Enabled Subsystem block, a To Multimedia File block, and a trigger
signal. For more information on the blocks used in this example, see the

From Multimedia File, Insert Text, Enabled Subsystem, and To Multimedia
File block reference pages.
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Combine Video and Audio Streams into a Single
Video File
In this example, you use the From Multimedia File blocks to import video and

audio streams into a Simulink model. You then write the audio and video to
a single file using the To Multimedia File block.

You can open the example model by typing

ex_combine_video_and_audio_streams

on the MATLAB command line.

1 Run your model. The model creates a multimedia file called output.avi in
your current folder.

2 Play the multimedia file using a media player. The original video file now
has an audio component to it.

Setting Up the Video Input Block

The From Multimedia File block imports a video file into the model. During
import, the Inherit sample time from file check box is deselected, which
enables the Desired sample time parameter. The other default parameters
are accepted.

The From Multimedia File block used for the input video file inherits its
sample time from the vipmen.avi file. For video signals, the sample time
equals the frame period. The frame period is defined as 1/(frame rate).
Because the input video frame rate is 30 frames per second (fps), the block
sets the frame period to 1/30 or 0.0333 seconds per frame.

Setting Up the Audio Input Block
The From Multimedia Filel block imports an audio file into the model.

The Samples per audio frame parameter is set to 735. This output audio

frame size is calculated by dividing the frequency of the audio signal (22050
samples per second) by the frame rate (approximately 30 frames per second).
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You must adjust the audio signal frame period to match the frame period of
the video signal. The video frame period is 0.0333 seconds per frame. Because
the frame period is also defined as the frame size divided by frequency, you
can calculate the frame period of the audio signal by dividing the frame size of
the audio signal (735 samples per frame) by the frequency (22050 samples per
second) to get 0.0333 seconds per frame.

frame period = (frame size)/(frequency)
frame period = (735 samples per frame)/(22050 samples per second)
frame period = 0.0333 seconds per frame
Alternatively, you can verify that the frame period of the audio and video
signals is the same using a Simulink Probe block.

Setting Up the Output Block

The To Multimedia File block is used to output the audio and video signals
to a single multimedia file. The Video and audio option is selected for the
Write parameter and One multidimensional signal for the Image signal
parameter. The other default parameters are accepted.

Configuration Parameters
You can locate the Configuration Parameters by selecting

Simulation > Configuration Parameters. The parameters, on the Solver
pane, are set as follows:

e Stop time = 10

* Type = Fixed-step

e Solver =Discrete (no continuous states)

Import MATLAB Workspace Variables

You can import data from the MATLAB workspace using the Video From
Workspace block, which is created specifically for this task.
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Use the Signal parameter to specify the MATLAB workspace variable from
which to read. For more information about how to use this block, see the
Video From Workspace block reference page.

Import a Live Video Stream

Image Acquisition Toolbox provides functions for acquiring images and video
directly into MATLAB and Simulink from PC-compatible imaging hardware.
You can detect hardware automatically, configure hardware properties,
preview an acquisition, and acquire images and video.
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See the live video processing demos to view demos that use the Image
Acquisition Toolbox together with Computer Vision System Toolbox blocks. To
see the full list of Computer Vision System Toolbox demos, type visiondemos
at the MATLAB command prompt.
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Colorspace Formatting and Conversions

In this section...

“Resample Image Chroma” on page 1-23
“Convert Intensity to Binary Images” on page 1-30

“Convert R'G’B’ to Intensity Images” on page 1-42

“Process Multidimensional Color Video Signals” on page 1-47

Resample Image Chroma

The Y’CbCr color space separates the luma (Y’) component of an image from
the chroma (Cb and Cr) components. Luma and chroma, which are calculated
using gamma corrected R, G, and B (R’, G’, B’) signals, are different quantities
than the CIE chrominance and luminance. Because the human eye is more
sensitive to changes in luma than to changes in chroma, you can reduce the
bandwidth required for transmission or storage of a signal by removing some
of the color information. For this reason, this color space is often used for
digital encoding and transmission applications. In the following example, you
use the Chroma Resampling block to downsample the Cb and Cr components
of an image:

1 Define an RGB image in the MATLAB workspace. To read in an RGB
image from a TIF file, at the MATLAB command prompt, type

I= imread('autumn.tif');

I is a 206-by-345-by-3 array of 8-bit unsigned integer values. Each plane of
this array represents the red, green, or blue color values of the image.

2 To view the image this array represents, at the MATLAB command
prompt, type

imshow(I)
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) Figure 1 =1of x|

File Edit ‘iew Insert Tools Deskbop  Window

n%l%lﬁla{‘volﬂ%mlﬂm@

3 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

Image From Computer Vision System 1

Workspace Toolbox > Sources

Image Pad Computer Vision System 1
Toolbox > Utilities

Color Space Computer Vision System 2

Conversion Toolbox > Conversions

Chroma Resampling Computer Vision System 2
Toolbox > Conversions

Video Viewer Computer Vision System 1
Toolbox > Sinks

Selector Simulink > Signal Routing 3

4 Position the blocks as shown in the following figure.
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The blocks to the left of and including the Chroma Resampling block
represent the transmission portion of the model. The remaining blocks
represent the receiving portion of the model. Once you have assembled
these blocks, you are ready to set your block parameters. To do this,
double-click the blocks, modify the block parameter values, and click OK.

5 Use the Image from Workspace block to import your image from the
MATLAB workspace. Set the Value parameter to I.

6 Use the Image Pad block to change the dimensions of the I array from
206-by-345-by-3 to 206-by-346-by-3. You are changing these dimensions
because the Chroma Resampling block requires that the dimensions of the
input be divisible by 2. Set the block parameters as follows:

¢ Method = Symmetric
¢ Pad rows at = Right
¢ Pad size along rows = 1

¢ Pad columns at = No padding
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E Function Block Parameters: Image Pad x|

—Image Pad [mazk] (link)

Perfarm two-dimensional padding of an input image.

Pad your image by adding rows to the top and/or botbom of wour image and columne
to the left and/or right zide of pour image. To specify a different padding size at the
top and bottom or left and right gside of pour image, use a two-element vector, The first
element denotes the padding at the top or left side of vour image. The second
element denotes the padding at the bottom or right side of wour image.

‘fou can pad your matix with & constant value, specified by the Value parameter or
the Fyal input port. 1n addition, you can pad your matrix by repeating its border
values, uzing itz mirrar image, of using a circular repetition of its elements.

—Parameters

tethod: I Syummetric

Specif_l,l:l Pad zize

Lol Lef L]

Pad roves at:l Right
Pad zize along roms:
1

Pad colunins at:l Mo padding LI

ak I Cancel

The Image Pad block adds one column to the right of each plane of the
array by repeating its border values. This padding minimizes the effect
of the pixels outside the image on the processing of the image.

Note When processing video streams, it is computationally expensive to
pad every video frame. You should change the dimensions of the video
stream before you process it with Computer Vision System Toolbox

blocks.
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7 Use the Selector blocks to separate the individual color planes from the
main signal. This simplifies the color space conversion section of the model.
Set the Selector block parameters as follows:

¢ Number of input dimensions = 3
e 1
= Index Option = Select all
e 2
= Index Option = Select all
e 3
= Index Option = Index vector (dialog)

- Index =1

Set the Selectorl block parameters as follows:
¢ Number of input dimensions = 3
e 1
= Index Option = Select all
e 2
= Index Option = Select all
e 3
= Index Option = Index vector (dialog)

= Index=2

Set the Selector2 block parameters as follows:
¢ Number of input dimensions = 3
e 1
- Index Option = Select all
e 2
- Index Option = Select all
e 3
- Index Option = Index vector (dialog)

- Index=3
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8 Use the Color Space Conversion block to convert the input values from the
R’G’B’ color space to the Y'CbCr color space. The prime symbol indicates
a gamma corrected signal. Set the Image signal parameter to Separate
color signals. To do this, select File > Image Signal from the viewer.

9 Use the Chroma Resampling block to downsample the chroma components

of the image from the 4:4:4 format to the 4:2:2 format. Use the default
parameters.

E Function Block Parameters: Chroma Resampling x|

—Chroma Resampling [mask] [link]

Downzample or upzample chioma components of avCbCr signal to reduce
the bandwidth and/or storage requirements.

—Parameters
Hesampling:l 4440422 LI
Antialiazing filter:l Drefault ;I
Cancel Help | Apply |

The dimensions of the output of the Chroma Resampling block are smaller

than the dimensions of the input. Therefore, the output signal requires less
bandwidth for transmission.

10 Use the Chroma Resampling1 block to upsample the chroma components of

the image from the 4:2:2 format to the 4:4:4 format. Set the Resampling
parameter to 4:2:2 to 4:4:4.

11 Use the Color Space Conversionl block to convert the input values from the

Y’CbCr color space to the R'G’B’ color space. Set the block parameters as
follows:

e Conversion=Y'CbCr to R'G'B"

¢ Image signal = Separate color signals

12 Use the Video Viewer block to display the recovered image. Set the Image
signal parameter to Separate color signals.

13 Connect the blocks as shown in the following figure.
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14 Configure Simulink to display signal dimensions next to each signal line.
Click Format > Port/Signal Displays > Signal Dimensions.

15 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

¢ Solver pane, Stop time =0
¢ Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

16 Run the model.

The recovered image appears in the Video Viewer window.
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) Video Viewer =10l x|
File Tools WView Playback Help

EICEIEEYS
=@

100% -]

Ready

RGE 206x346  T=0.000

17 Examine the signal dimensions in your model. The Chroma Resampling
block downsamples the Cb and Cr components of the image from 206-by-346
matrices to 206-by-173 matrices. These matrices require less bandwidth

for transmission while still communicating the information necessary to
recover the image after it is transmitted.

You have used the Chroma Resampling block to downsample the Cb and

Cr components of an image. For more information about this block, see the
Chroma Resampling block reference page.

Convert Intensity to Binary Images

¢ “Thresholding Intensity Images Using Relational Operators” on page 1-31

¢ “Thresholding Intensity Images Using the Autothreshold Block” on page
1-36
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Binary images contain Boolean pixel values that are either 0 or 1. Pixels
with the value 0 are displayed as black; pixels with the value 1 are displayed
as white. Intensity images contain pixel values that range between the
minimum and maximum values supported by their data type. Binary images
can contain only Os and 1s, but they are not binary images unless their data

type is Boolean.

Thresholding Intensity Images Using Relational Operators

You can use the Relational Operator block to perform a thresholding operation
that converts your intensity image to a binary image. This example shows
you how to accomplish this task:

1 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity
Image From File Computer Vision System 1
Toolbox > Sources
Video Viewer Computer Vision System 2
Toolbox > Sinks
Relational Operator Simulink > Logic and Bit 1
Operations
Constant Simulink > Sources 1

2 Position the blocks as shown in the following figure.
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RI=TEY

File Edit view Simulation Format Tools Help
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Operator

Image From File
TR

Constant

Ready [100% | | |odeas 4

3 Use the Image from File block to import your image. In this example the
image file is a 256-by-256 matrix of 8-bit unsigned integer values that
range from 0 to 255. Set the File name parameter to rice.png

4 Use the Video Viewerl block to view the original intensity image. Accept
the default parameters.

5 Use the Constant block to define a threshold value for the Relational
Operator block. Since the pixel values range from 0 to 255, set the
Constant value parameter to 128. This value 1s image dependent.

6 Use the Relational Operator block to perform a thresholding operation
that converts your intensity image to a binary image. Set the Relational
Operator parameter to >. If the input to the Relational Operator block
1s greater than 128, its output is a Boolean 1; otherwise, its output is
a Boolean 0.
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=] Function Block Parameters: Relational Operator x|

Relational Operator

Applies the selected relational operator to the inputs and outputs the result. The top (or left) input
corresponds to the first operand.

Main | Signal Attributes |

Relational operator: |:> LI

[V | Enable zero-crossing detection

Sample time (-1 for inherited):

|-1
JI oK I Cancel Help Apply

7 Use the Video Viewer block to view the binary image. Accept the default
parameters.

8 Connect the blocks as shown in the following figure.

=] doc_thresholding oy =] S|

File Edit View Simulaton Format Tools Help

D|ﬁﬂ@|éﬁ&|<b=ﬁ>‘{r|fﬂ2 3 ll:.: INDrmaI jlﬂﬁ
ice.png Im=gs - - >
- Relstionzl
Image From File Ciperator
128 Video Views
Constant
L pelimage
Video Viewsrd
Ready [1002%% [ |ode4s v
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9 Set the configuration parameters. Open the Configuration dialog box by

selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step
® Solver pane, Solver = Discrete (no continuous states)

10 Run your model.

The original intensity image appears in the Video Viewerl window.

J Video Viewerl -10| x|
File Tools WView Playback Help b

B O & e | ]| ~|
R L =

Reacy | 256256 T=0.000

The binary image appears in the Video Viewer window.
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=

Fil=  Tools View Playback Help 1u
IR
SR e =

Ready [ 256256 T=0.000

Note A single threshold value was unable to effectively threshold this
image due to its uneven lighting. For information on how to address this
problem, see “Correct Nonuniform Illumination” on page 7-9.

You have used the Relational Operator block to convert an intensity image
to a binary image. For more information about this block, see the Relational
Operator block reference page in the Simulink documentation. For additional

information, see “Converting Between Image Types” in the Image Processing
Toolbox documentation.
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Thresholding Intensity Images Using the Autothreshold Block

In the previous topic, you used the Relational Operator block to convert an
intensity image into a binary image. In this topic, you use the Autothreshold
block to accomplish the same task. Use the Autothreshold block when lighting
conditions vary and the threshold needs to change for each video frame.

1 If the model you created in “Thresholding Intensity Images Using
Relational Operators” on page 1-31 is not open on your desktop, you can
open an equivalent model by typing

ex_thresholding

at the MATLAB command prompt.

=] doc_thresholding oy ] 4
File Edit View Simulaton Format Tools Help
DISeEHE | sEBER|(E= 4 (22 b 5o [[rom 7| &

rice.png Im=gs -

| .
Ll =C
Wiewsr
I z - Relstionzl
mage From File Operator _ _
128 Video Viewsr

Constant

Ready [100%% [ [ |ode4s v

2 Use the Image from File block to import your image. In this example the
image file is a 256-by-256 matrix of 8-bit unsigned integer values that
range from 0 to 255. Set the File name parameter to rice.png

3 Delete the Constant and the Relational Operator blocks in this model.

4 Add an Autothreshold block from the Conversions library of the Computer
Vision System Toolbox into your model.
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5 Connect the blocks as shown in the following figure.

=] doc_thresholding * oy ] 4
File Edit View Simulaton Format Tools Help

DISeEHE | sEBER|(E= 4 (22 b 5o [[rom 7| &

ice.png Irmags | Autothresheld BW e Image \:r:f:
Imags From Fils Autothreshold Video Views
L | Image 1’::"?::
Video Viewsrd
Ready [100%% [ [ |ode4s v

6 Use the Autothreshold block to perform a thresholding operation that
converts your intensity image to a binary image. Select the Output

threshold check box.
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E! Function Block Parameters: Autothreshold x|

—Autathreshold
Automatically converts an intenzity imaage to a binary image.  Thiz block uses Otzu's method,
which determines the threzhald by zplitting the histogram of the input image such that the

variance for each of the pixel groups iz minimized.

Optionally, the block can autput & metric that indicates effectivengss of threshalding of the
input image.  The lower bound of the metric [zera) iz attainable only by images having a single

gray level, and the upper bound [one] iz attainable only by bwo-valued images.

bd air IFi:-ted-pnint I

—Parameters
Threzhalding nperatnr:l » :I
¥ Dutput threshald

[~ Dutput effectiveness metric

[~ Specify data range

[~ Scale threzhold

Apply |

(1] 4 | Cancel |

The block outputs the calculated threshold value at the Th port.

7 Add a Display block from the Sinks library of the DSP System Toolbox
library. Connect the Display block to the Th output port of the

Authothreshold block.

Your model should look similar to the following figure:
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8 Double-click the Image From File block. On the Data Types pane, set the
Output data type parameter to double.

9 If you have not already done so, set the configuration parameters. Open the
Configuration dialog box by selecting Configuration Parameters from
the Simulation menu. Set the parameters as follows:

® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step
® Solver pane, Solver = Discrete (no continuous states)

10 Run the model.

The original intensity image appears in the Video Viewerl window.
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The binary image appears in the Video Viewer window.
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In the model window, the Display block shows the threshold value,
calculated by the Autothreshold block, that separated the rice grains from
the background.
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You have used the Autothreshold block to convert an intensity image to a
binary image. For more information about this block, see the Autothreshold
block reference page in the Computer Vision System Toolbox Reference. To
open a demo model that uses this block, type vipstaples at the MATLAB
command prompt.

Convert R’G’B’ to Intensity Images

The Color Space Conversion block enables you to convert color information
from the R’G’B’ color space to the Y’CbCr color space and from the Y'CbCr
color space to the R’G’B’ color space as specified by Recommendation ITU-R
BT.601-5. This block can also be used to convert from the R’G’B’ color space to
intensity. The prime notation indicates that the signals are gamma corrected.

Some image processing algorithms are customized for intensity images. If
you want to use one of these algorithms, you must first convert your image
to intensity. In this topic, you learn how to use the Color Space Conversion
block to accomplish this task. You can use this procedure to convert any
R’G’B’ image to an intensity image:
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1 Define an R°'G’'B’ image in the MATLAB workspace. To read in an R'G'B’
image from a JPG file, at the MATLAB command prompt, type

I= imread('greens.jpg');

I is a 300-by-500-by-3 array of 8-bit unsigned integer values. Each plane of
this array represents the red, green, or blue color values of the image.

2 To view the image this matrix represents, at the MATLAB command
prompt, type

imshow(I)

2 Figure 1 0] x|
N

File Edit View Insert Tools Deskiop Window Help

DS K RaAM® € 0B 0O

3 Create a new Simulink model, and add to it the blocks shown in the
following table.
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Block Library Quantity
Image From Computer Vision System 1
Workspace Toolbox > Sources
Color Space Computer Vision System 1
Conversion Toolbox > Conversions
Video Viewer Computer Vision System 1

Toolbox > Sinks

4 Position the blocks as shown in the following figure.

it

File Edit Wiew Simulation Format Tools  Help

D SHE 2R e 4 92| » ufion  [Nomad =] 5 e

chechker_boad(10}) Image i%ﬁc? Image ‘.Yi::eor
Irmage From Workspace Golr Space Wideo Wizwer
Conversion
Ready [100% | [ [odeas v

Once you have assembled the blocks needed to convert a R’G’B’ image to an
intensity image, you are ready to set your block parameters. To do this,
double-click the blocks, modify the block parameter values, and click OK.

5 Use the Image from Workspace block to import your image from the
MATLAB workspace. Set theValue parameter to I.

6 Use the Color Space Conversion block to convert the input values from the

R’G’B’ color space to intensity. Set the Conversion parameter to R'G'B'
to intensity.
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) Function Block Parameters: Color Space Conversion |

— Color Space Conversion [mask] (link]

Coreverts color information between color zpaces.

|Jze the Corversion parameter to specify the color spaces you are converting
between, our choices are R'G'B' to v"ChCr, ¥'ChCr to B'G'E', R'G'B' ta intengity,
R'G'B' to HSY, HSY to R'G'E", sR'G'B" toxvZ, »vZ to sR'G'E', sR'G'B' to L*a"b", and
L*a*b* to sR'G'B".

All converziong support double-precizsion floating-point and single-precizion

floating-point inputs, The conversions from R'G'B' to intengity and betveen the R'G'E'
and "ChCr color zpaces alzo support 3-bit unzigned integer inputs,

—Parameters
Cnnversion:l R'G'E" to inkenszity LI
Image signal:l One multidimensional signal LI

7 View the modified image using the Video Viewer block. Accept the default

parameters.

8 Connect the blocks so that your model is similar to the following figure.

~iBix

File Edit Wiew Simulation Format Tools Help

O @EHE&| & BB 42z II'ID.D INormaI || B gk

N - RGE o R
5 = inte nsity = 92 Viewer
Image From Workspace Golor Space Video Viewer
Conversion
Ready [100% | [ [odeas v

9 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:
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® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

10 Run your model.
The image displayed in the Video Viewer window is the intensity version

of the greens. jpg image.

) video Viewer -0l x|
File Tools View Playback Help

B O & & [ ~|
C R e e

I:300:500 T=0.000

Ready

In this topic, you used the Color Space Conversion block to convert color
information from the R’G’B’ color space to intensity. For more information on
this block, see the Color Space Conversion block reference page.
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Process Multidimensional Color Video Signals

The Computer Vision System Toolbox software enables you to work with
color images and video signals as multidimensional arrays. For example,
the following model passes a color image from a source block to a sink block
using a 384-by-512-by-3 array.

JiL=IE

File Edit Wiew Simulakion Format  Tools  Help

DEsEHES | fER| s 4[] II1D.U [Nomal =]

[sstestzxs] o f| Videa
PIMEER s

PEPPEE.FRD Irnage

Imzge From File Wideo Wiewer

Ready [10d% [odeas v
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) video Viewer O] x|
File Tools Wiew Playback Help ~
B[ 0% /&G o

CRR o e

Feady RGE 354512 T=10.000

You can choose to process the image as a multidimensional array by setting
the Image signal parameter to One multidimensional signal in the Image
From File block dialog box.
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[Z]source Block Parameters: Image From File

Image Fram File

Reads an image from a file.

|Jze the File name parameter to gpecify the image file you want bo import into pour
model. Uge the Sample time parameter to zet the zample period of the block.

IDataT_l,Jpes |

Parameters

File name: Ipeppers.png Browse. . |

Sample tirme: Iinf

Image signal:l One multidimensional signal :I

0k I Cancel | Help

The blocks that support multidimensional arrays meet at least one of the

following criteria:

® They have the Image signal parameter on their block mask.

® They have a note in their block reference pages that says, “This block

supports intensity and color images on its ports.”

® Their input and output ports are labeled “Image”.

You can also choose to work with the individual color planes of images or
video signals. For example, the following model passes a color image from a
source block to a sink block using three separate color planes.
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) video Viewerl O] x|
File Tools Wiew Playback Help ~
B[ 0% /&G o

CRR o e

Feady RGE 354512 T=10.000

To process the individual color planes of an image or video signal, set the
Image signal parameter to Separate color signals in both the Image
From File and Video Viewer block dialog boxes.
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E Source Block Parameters: Image From File x|

Image From File

Reads an image from a file.

|Jze the File hame parameter to specify the image file you want ta impart into your
model. Uge the Sample time parameter to zet the zample period of the block.

I Drata Types |

—Parameters

File narme; Ipeppers.png Brovese. . |

Sample time: Iinf

Image signal:l Separate color gignalz j

Dutput port labels: IHIGIB

0k I Cancel | Help |

) Video Viewerl

File Tools View Playback Help

v Open at Skark of Simulation I 10024 - I
Image Signal One Mulki-Dimensional Signal
Configuration Sek Separate Color Signals

Expart to Imaage Toal Ctrl+E
Close Chrl+w
Close all

Note The ability to output separate color signals is a legacy option. It is
recommend that you use multidimensional signals to represent color data.

If you are working with a block that only outputs multidimensional arrays,
you can use the Selector block to separate the color planes. For an example of
this process, see “Measure an Angle Between Lines” on page 3-16. If you are
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working with a block that only accepts multidimensional arrays, you can use
the Matrix Concatenation block to create a multidimensional array. For an
example of this process, see “Find the Histogram of an Image” on page 7-2.

1-53



1 Input, Output, and Conversions

Data Formats

In this section...

“Video Formats” on page 1-54
“Video Data Stored in Column-Major Format” on page 1-55

“Image Formats” on page 1-55

Video Formats

Video data 1s a series of images over time. Video in binary or intensity format
is a series of single images. Video in RGB format is a series of matrices
grouped into sets of three, where each matrix represents an R, G, or B plane.

Defining Intensity and Color

Video data is a series of images over time. Video in binary or intensity format
is a series of single images. Video in RGB format is a series of matrices
grouped into sets of three, where each matrix represents an R, G, or B plane.

The values in a binary, intensity, or RGB image can be different data types.
The data type of the image values determines which values correspond to
black and white as well as the absence or saturation of color. The following
table summarizes the interpretation of the upper and lower bound of each
data type. To view the data types of the signals at each port, from the Format
menu, point to Port/Signal Displays, and select Port Data Types.

Black or Absence of | White or Saturation
Data Type Color of Color
Fixed point Minimum data type Maximum data type
value value
Floating point 0 1

Note The Computer Vision System Toolbox software considers any data
type other than double-precision floating point and single-precision floating
point to be fixed point.
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For example, for an intensity image whose image values are 8-bit unsigned
integers, 0 is black and 255 is white. For an intensity image whose image
values are double-precision floating point, O is black and 1 is white. For an
Iintensity image whose image values are 16-bit signed integers, -32768 1s
black and 32767 is white.

For an RGB image whose image values are 8-bit unsigned integers, 0 0 0
1s black, 255 255 255 is white, 255 0 0 1s red, 0 255 0 1s green, and 0 0 255
is blue. For an RGB image whose image values are double-precision
floating point, 0 0 0 1s black, 1 1 1 is white, 1 0 0 is red, 0 1 O is green,
and 0 0 1 is blue. For an RGB image whose image values are 16-bit
signed integers, -32768 -32768 -32768 is black, 32767 32767 32767 is
white, 32767 -32768 -32768 is red, -32768 32767 -32768 is green, and
-32768 -32768 32767 is blue.

Video Data Stored in Column-Major Format

The MATLAB technical computing software and Computer Vision System
Toolbox blocks use column-major data organization. The blocks’ data buffers
store data elements from the first column first, then data elements from the
second column second, and so on through the last column.

If you have imported an image or a video stream into the MATLAB workspace
using a function from the MATLAB environment or the Image Processing
Toolbox, the Computer Vision System Toolbox blocks will display this

image or video stream correctly. If you have written your own function or
code to import images into the MATLAB environment, you must take the
column-major convention into account.

Image Formats

In the Computer Vision System Toolbox software, images are real-valued
ordered sets of color or intensity data. The blocks interpret input matrices as
images, where each element of the matrix corresponds to a single pixel in the
displayed image. Images can be binary, intensity (grayscale), or RGB. This
section explains how to represent these types of images.
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Binary Images
Binary images are represented by a Boolean matrix of Os and 1s, which
correspond to black and white pixels, respectively.

For more information, see “Binary Images” in the Image Processing Toolbox™
documentation.

Intensity Images

Intensity images are represented by a matrix of intensity values. While
Intensity images are not stored with colormaps, you can use a gray colormap
to display them.

For more information, see “Grayscale Images” in the Image Processing
Toolbox documentation.

RGB Images

RGB images are also known as a true-color images. With Computer Vision
System Toolbox blocks, these images are represented by an array, where the
first plane represents the red pixel intensities, the second plane represents
the green pixel intensities, and the third plane represents the blue pixel
intensities. In the Computer Vision System Toolbox software, you can

pass RGB images between blocks as three separate color planes or as one
multidimensional array.

For more information, see “Truecolor Images” in the Image Processing
Toolbox documentation.
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Display

In this section...

“View Streaming Video in MATLAB using Video Player and Deployable
Video Player System Objects” on page 2-2

“Preview Video in MATLAB using MPlay Function” on page 2-2

“To Video Display Block” on page 2-4

“View Video in Simulink using MPlay Function as a Floating Scope” on
page 2-4

“MPlay” on page 2-7

View Streaming Video in MATLAB using Video Player
and Deployable Video Player System Obijects

Video Player System Object

Use the video player System object when you require a simple video display
in MATLAB.

For more information about the video player object, see the
vision.VideoPlayer reference page.

Deployable Video Player System Obiject

Use the deployable video player object as a basic display viewer designed for
optimal performance. This block supports code generation for the Windows®
platform.

For more information about the Deployable Video Player block, see the
vision.DeployableVideoPlayer object reference page.

Preview Video in MATLAB using MPlay Function

The MPlay function enables you to view videos represented as variables in the
MATLAB workspace.
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You can open several instances of the MPlay function simultaneously to view
multiple video data sources at once. You can also dock these MPlay GUIs in
the MATLAB desktop. Use the figure arrangement buttons in the upper-right
corner of the Sinks window to control the placement of the docked GUIs.

The MPlay GUI enables you to view videos directly from files without having
to load all the video data into memory at once. The following procedure shows
you how to use the MPlay GUI to load and view a video one frame at a time:

']

1 On the MPlay GUI, click open file element,

2 Use the Connect to File dialog box to navigate to the multimedia file you
want to view in the MPlay window.

For example, navigate to
$matlabroot\toolbox\vision\visiondemos\vipmen.avi.

Click Open. The first frame of the video appears in the MPlay window.

) MPlay [1] - File: ¥ipmen.avi o |
File Tools Wiew Playback Help o

D@%@||Q|@laiﬂ? |114% LI

CHWa m oo e

Stopped RGE120160  [100% (30 fps)  [14283
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Note The MPlay GUI supports AVI files that the mmreader supports.

3 Experiment with the MPlay GUI by using it to play and interact with the
video stream.

View Video in Simulink using the Video Viewer and
To Video Display Blocks

Video Viewer Block

Use the Video Viewer block when you require a wired-in video display with
simulation controls in your Simulink model. The Video Viewer block provides
simulation control buttons directly from the GUI. The block integrates play,
pause, and step features while running the model and also provides video
analysis tools such as pixel region viewer.

For more information about the Video Viewer block, see the Video Viewer
block reference page.

To Video Display Block

Use the To Video Display block in your Simulink model as a simple display
viewer designed for optimal performance. This block supports code generation
for the Windows platform.

For more information about the To Video Display block, see the To Video
Display block reference page.

View Video in Simulink using MPlay Function as a
Floating Scope

The MPlay GUI enables you to view video signals in Simulink models without
adding blocks to your model.

You can open several instances of the MPlay GUI simultaneously to view
multiple video data sources at once. You can also dock these MPlay GUIs in
the MATLAB desktop. Use the figure arrangement buttons in the upper-right
corner of the Sinks window to control the placement of the docked GUIs.
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Set Simulink simulation mode to Normal to use mplay . MPlay does not work
when you use “Accelerating Simulink Models” on page 8-8.

The following procedure shows you how to use MPlay to view a Simulink

signal:

1 Open a Simulink model. At the MATLAB command prompt, type

vipmplaytut

E!vipmplaytut

File Edit Yiew Simulation Format Tools Help

=10 ]

MPlay: Working with Simulink

G-bit RGE
=signal bus

&-bit RSB
component signalks

Single-pecision
RGE =zignal bus

RGE bus after RGE componant
mitstion signak

Source-R
L
wipren. bin Soume > - GD:DUESI;LIQn;age »
SoureeB o Fotate
™ Angle
RGE Video Fotame
[T}
? Retation
"

Ready

Eus Selkector

[100%% [

|FixedstepDiscrete

4

2 Open an MPlay GUI by typing mplay on the MATLAB command line.

3 Run the model.

4 Select the signal line you want to view. For example, select the bus signal

coming out of the Rotate block.

5 On the MPlay GUI, click Connect to Simulink Signal GUI element, t@

The video appears in the MPlay window.
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=) MPlay [1] - Simulink: Rotate -0 x|
'}

File Tools WView Simulaton Help
D B[E | 8| 0| & Q| Ewe -
mouo» | @ o sl

Running RGB:200x200 T=2287.333

6 Change to floating-scope mode by clicking the persistent connect GUI
element, ET_ button.

7 Experiment with selecting different signals and viewing them in the
MPlay window. You can also use multiple MPlay GUIs to display different

Simulink signals.

Note During code generation, the Simulink® Coder™ does not generate code
for the MPlay GUI.
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MPlay
The following figure shows the MPlay GUI containing an image sequence.
B MPlay [1] - File: viptrain.avi o -E | ]
File Tools VWiew Playback Help k]

Toolbar —» 1) [ & |3 880 % | | O By | R 2

Playback Toolbar — KM 44 41 ® P D » M | 03| es =

100%

Video Frames ——

Stopped RGB:240x360 ||100% (30 fps) | 626 /626
'y

Video Status Type of Video

Frame size | Frame rate

Percentage
of frame rate

Current frame/Total frames
MNOTE: The +/- indicate playback direction

The following sections provide descriptions of the MPlay GUI toolbar buttons
and equivalent menu options.
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Toolbar Buttons

GUI | Menu Shortcut Keys Description
Equivalent and Accelerators
_nl File > New Ctrl+N Open a new MPlay GUI.
MPlay
File > Print Ctrl+P Print the current scope
Iy window. Printing is only
available when the scope
display is not changing. You
can enable printing by placing
the scope in snapshot mode,
or by pausing or stopping
model simulation.
To print the current scope
window to a figure rather
than sending it to your
printer, select File > Print
to figure.
=] File > Open Ctrl+O Connect to a video file.
el File > Ctrl+I Connect to a variable from the
Import from base MATLAB workspace.
Workspace
1—@ File > Connect to a Simulink signal.
Connect to
Simulink
Signal
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GUI | Menu Shortcut Keys Description
Equivalent and Accelerators
@ File > Export | Ctrl+E Send the current video
to Image Tool frame to the Image Tool.
For more information, see
“Using the Image Tool to
Explore Images” in the
Image Processing Toolbox
documentation.
The Image Tool only knows
the frame is an intensity
image if the colormap of
the frame is grayscale
(gray(256)). Otherwise, the
Image Tool assumes that the
frame is an indexed image
and disables the Adjust
Contrast button.
5 ) Tools > Video | V View information about the
Information video data source.
Tools > Pixel | N/A Open the Pixel Region
B Region tool. For more information
about this tool, see the
Image Processing Toolbox
documentation.
= Tools > Zoom | N/A Zoom in on the video display.
* | In
= Tools > Zoom | N/A Zoom out of the video display.
“ | Out
Tools > Pan N/A Move the image displayed in

the GUL
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GUI | Menu Shortcut Keys Description
Equivalent and Accelerators

Tools > N/A Scale video to fit GUI size
Maintain Fit automatically. Toggle the
to Window button on or off.
N/A N/A Enlarge or shrink the video

100%

display. This option is
available if you do not select
the Maintain Fit to Window
button.

Playback Toolbar — Workspace and File Sources

GUI | Menu Shortcut Keys Description
! Y P
Equivalent and Accelerators
7 Playback > F, Home Go to the first frame of the
Go to First video.
4 Playback > Up arrow Jump back ten frames.
Rewind
a Playback > Left arrow, Page Step back one frame.
Step Back Up
n Playback > S Stop the video.
Stop
P Playback > P, Space bar Play the video.
Play
I Playback > P, Space bar Pause the video. This button
Pause appears only when the video
is playing.
I Playback Right arrow, Page | Step forward one frame.
> Step Down
Forward
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GUI

Menu
Equivalent

Shortcut Keys

and Accelerators

Description

44

Playback >
Fast Forward

Down arrow

Jump forward ten frames.

M

Playback >
Go to Last

L, End

Go to the last frame of the
video.

Playback >
Jump to

dJ

Jump to a specific frame.

Playback >
Playback
Modes >
Repeat

R

Repeated video playback.

Playback >
Playback
Modes >
Forward play

Play the video forward.

Playback >
Playback
Modes >
Backwardplay

Play the video backward.

1

Playback >
Playback
Modes >
AutoReverse

play

A

Play the video forward and
backward.
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Playback Toolbar — Simulink Sources

GUI | Menu Shortcut Keys Description
Equivalent and Accelerators

n Simulation > | S Stop the video. This button
Stop also controls the Simulink

model.
P Simulation > | P, Space bar Play the video. This button
Start also controls the Simulink
model.

i Simulation > | P, Space bar Pause the video. This button

Pause also controls the Simulink
model and appears only when
the video is playing.

I» Simulation Right arrow, Page | Step forward one frame.
> Step Down This button also controls the
Forward Simulink model.

Simulation N/A Click this button to freeze the
> Simulink display in the MPlay window.
Snapshot

E?r* View > Ctrl+L In the model window,
Highlight highlight the Simulink
Simulink signal the MPlay GUI is
Signal displaying.

Simulation N/A Indicates persistent Simulink
> Floating connection. In this mode, the
Signal MPlay GUI always associates
Connection with the Simulink signal you
(not selected) selected before you clicked

the Connect to Simulink
Signal button.

é‘?— Simulation N/A Indicates floating Simulink
> Floating connection. In this mode, you
Signal can click different signals in

2-12
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GUI | Menu Shortcut Keys Description
Equivalent and Accelerators
Connection the model, and the MPlay
(selected) GUI displays them. You can
use only one MPlay GUI in
floating-scope mode at a time.
Configuration

The MPlay Configuration dialog box enables you to change the behavior and
appearance of the GUI as well as the behavior of the playback shortcut keys.

¢ To open the Configuration dialog box, select File > Configuration

Set > Edit.

¢ To save the configuration settings for future use, select
File > Configuration Set > Save as.

Note By default, the MPlay GUI uses the configuration settings from the
file mplay.cfg. Create a backup copy of the file to store your configuration

settings.

® To load a preexisting configuration set, select File > Configuration

Set > Load.

Configuration Core Pane

The Core pane controls the graphic user interface (GUI) general and source

settings.
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= ):MPlay [1] - Configuration

Core | Sources I Yisuals I Tu:u:ulsl

Name Description
General I Scope user interface settings
Source LI Cornmon source setkings

Cpkions ... | Ik Cancel Apply

General Ul

Click General UI, and then select the Options button to open the General
UI Options dialog box.

= J: MPlay [1] - CorezGeneral UI Options x|

—General UL Options

[ Display the full source path in the title bar

Cpen message log: |for warn/faill messages - |

oK Cancel | Apply

If you select the Display the full source path in the title bar check box,
the full Simulink path appears in the title bar. Otherwise, the title bar
displays a shortened name.

Use the Message log opens parameter to control when the Message log
window opens. You can use this window to debug issues with video playback.
Your choices are for any new messages, for warn/fail messages, only
for fail messages, or manually.

Source Ul

Click Source UI, and then click the Options button to open the Source Ul
Options dialog box.
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= ): MPlay - CorezSource UI Options x|

Source UI Options

¥ Keyboard commands respect source playback modes

Recently used sources list; |3 entries

oK Cancel Apply

If you select the Keyboard commands respect playback modes check
box, the keyboard shortcut keys behave in response to the playback mode
you selected.

Using the Keyboard commands respect playback modes
Open and play a video using MPlay.

1 Select the Keyboard commands respect playback modes check box.

2 Select the Backward playback button.

¢ Using the right keyboard arrow key moves the video backward, and
using the left keyboard arrow key moves the video forward.

e With MPlay set to play backwards, the keyboard “forward” performs
“forward with the direction the video is playing”.

To disconnect the keyboard behavior from the MPlay playback settings, clear
the check box.

Use the Recently used sources list parameter to control the number of
sources you see in the File menu.
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Configuration Sources Pane

The Sources pane contains the GUI options that relate to connecting to
different sources. Select the Enabled check box next to each source type to
specify to which type of source you want to connect the GUI.

«):MPlay [1] - Configuration x|
Core Sources | Visuals I Tools I
Enabled |Mame Description
I Simulink Connect ko Simulink signal
v File Connect ko file
v Workspace Import Fram MATLAE workspace
Options ... | Ok Cancel Apply

e (Click File, and then click the Options button to open the Sources:File

Options dialog box.

= ): MPlay - Sources:File Options

File Source Options

Default open file path: IH: i

Ok

Cancel

Apply

Use the Default open file path parameter to control the folder that is
displayed in the Connect to File dialog box. The Connect to File dialog
box becomes available when you select File > Open.

¢ (Click Simulink, and then click the Options button to open the

Sources:Simulink Options dialog box.
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= ): MPlay [1] - Sources:Simulink Options x|

simulink Source Cptions

¥ Load Simulink model if not open

Connect scope on selection of: | Signal lines anly ;I

Signal lines only
Signal lines or blocks
- Lt

You can have the Simulink model associated with an MPlay GUI to open
with MPlay. To do so, select the Load Simulink model if not open check

box.

Select Signal lines only to sync the video display only when you select
a signal line. If you select a block the video display will not be affected.

Select Signal lines or blocks to sync the video display to the signal line or
block you select. The default is Signal lines only.

Configuration Visuals

The Visuals pane contains the name of the visual type and its description.

Pane

= ): MPlay [1] - Configuration

Core I Sources Visuals | Tools I

Enabled |MName Descrintion
=2 Video Video visualization
I User-defined Ve |User-defined vector visualization
I Time Vector Time vector visualization
— Frequency Vect: Frequency vector visualization
I Statistics Statistics visualization

Options ... |

QK Cancel

Apply
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Configuration Tools Pane

The Tools pane contains the tools that are available on the MPlay GUI. Select
the Enabled check box next to the tool name to specify which tools to include
on the GUI.

«):MPlay [1] - Configuration

Care I Sources I Wisuals Tools

Enabled |MName Description
2 Image Tool Display the frame in Image Tool
2 Pixel Reqgion Display pixel infarmation For a region in the frame
2 Image Mavigation Tc/Pan or zoom the Frame
2 Instrumentation Set| Save o load mulkiple scope settings

Cpkions ... | Ik Cancel Apply

Click Image Tool, and then click the Options button to open the Image
Tool Options dialog box.

= ) MPlay - Tools=Image Tool Options x|

Export to Image Tool Options

¥ Open new Image Tool window for each expart

(0]4 Cancel Apply

Select the Open new Image Tool window for export check box if you want
to open a new Image Tool for each exported frame.

Pixel Region

Select the Pixel Region check box to display and enable the pixel region GUI
button. For more information on working with pixel regions, see Getting
Information about the Pixels in an Image.
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Image Navigation Tools
Select the Image Navigation Tools check box to enable the pan-and-zoom
GUI button.

Instrumentation Set
Select the Instrumentation Set check box to enable the option to load and
save viewer settings. The option appears in the File menu.

Video Information

The Video Information dialog box lets you view basic information about the
video. To open this dialog box, select Tools > Video Information or click

the information button 0 .

=) MPlay [1] - Video x|
— Video Info
Source type: File
Source name: C:\wiptrain. avi
Frame size: 290 H x 360 W
Color format: RGB

Source data type:  uint8
Display data type:  uintd
Source rate; 30 fps

Frame count: o2&

Ok

Color Map for Intensity Video

The Colormap dialog box lets you change the colormap of an intensity video.
You cannot access the parameters on this dialog box when the GUI displays
an RGB video signal. To open this dialog box for an intensity signal, select
Tools > Colormap or press C.
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=) MPlay [1] - Colormap x|

Calormap: I gray(258)| =

[~ Spedfy range of displayed pixel values [Inf to Inf]

Min: |0 Max: |255

0K I Cancel | Help Apply

Use the Colormap parameter to specify the colormap to apply to the intensity
video.

Sometimes, the pixel values do not use the entire data type range. In such
cases, you can select the Specify range of displayed pixel values check
box. You can then enter the range for your data. The dialog box automatically
displays the range based on the data type of the pixel values.

Frame Rate
The Frame Rate dialog box displays the frame rate of the source. It also lets

you change the rate at which the MPlay GUI plays the video and displays the
actual playback rate.

Note This dialog box becomes available when you use the MPlay GUI to
view a video signal.

The playback rate is the number of frames the GUI processes per second. You
can use the Desired playback rate parameter to decrease or increase the
playback rate. To open this dialog box, select Playback > Frame Rate or
press T.
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«): MPlay [1] - Frame Rate x|
—Frame Rate
Source rate; 30 frames sec
Desired playback rate: IW frames sec
Actual playback rate: 0.0 framesfsec
—Frame Drop
[~ allow frame drop to achieve desired playback rate

QK I Cancel Help

Apply

To increase the playback rate when system hardware cannot keep pace

with the desired rate, select the Allow frame drop to achieve desired
playback rate check box. This parameter enables the MPlay GUI to achieve
the playback rate by dropping video frames. Dropped video frames sometimes

cause lower quality playback.

«): MPlay [1] - Frame Rate x|
—Frame Rate
Source rate; 30 frames fsec
Desired playback rate: IW frames sec
Actual playback rate: 0.0 frames/fsec
—Frame Drop

V¥ allow frame drop to achieve desired playback rate

Minimum refresh rate: I 24 frames sec
Maximum refresh rate: I 32 frames sec
Playback schedule: Show 1 frame, Drop O frames

Refresh rate: 30 framessec

QK I Cancel Help

Apply

You can refine further the quality of playback versus hardware burden, by
controlling the number of frames to drop per frame or frames displayed.

For example, suppose you set the Desired playback rate to 80 frames/sec.
One way to achieve the desired playback rate is to set the Playback schedule
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to Show 1 frame, Drop 3 frames. Change this playback schedule, by
setting the refresh rates (which is how often the GUI updates the screen), to:

Maximum refresh rate: 21 frames/sec
Minimum refresh rate: 20 frames/sec

MPlay can achieve the desired playback rate (in this case, 80 frames/sec)
by using these parameter settings.

In general, the relationship between the Frame Drop parameters is:

show _ frames + drop _ frames

Desired _rate = refresh _rate *
show _ frames

In this case, the refresh_rate includes a more accurate calculation based on
both the minimum and maximum refresh rates.

Use the Minimum refresh rate and Maximum refresh rate parameters
to adjust the playback schedule of video display. Use these parameters in
the following way:

® Increase the Minimum refresh rate parameter to achieve smoother
playback.

® Decrease the Maximum refresh rate parameter to reduce the demand
on system hardware.

Saving the Settings of Multiple MPlay GUIs

The MPlay GUI enables you to save and load the settings of multiple GUI
instances. You only have to configure the MPlay GUIs associated with your
model once.

To save the GUI settings:

¢ Select File > Instrumentation Sets > Save Set

To open the preconfigured MPlay GUIs:

e Select File > Instrumentation Sets > Load Set
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You can save instrument sets for instances of MPlay connected to a source.
If you attempt to save an instrument set for an MPlay instance that is not
connected to a source, the Message Log displays a warning.

Message Log

The Message Log dialog box provides a system level record of configurations
and extensions used. You can filter what messages to display by Type and
Category, view the records, and display record details.

® The Type parameter allows you to select either A11, Info, Warn, or Fail
message logs.

¢ The Category parameter allows you to select either Configuration or
Extension message summaries.

® The Configuration message indicates a new configuration file loaded.

e The Extension message indicates a registered component. For example,
a Simulink message, indicating a registered component, available for
configuration.

Status Bar
Along the bottom of the MPlay viewer is the status bar. It displays

information, such as video status, Type of video playing (I or RGB), Frame size,
Percentage of frame rate, Frame rate, and Current frame: Total frames.

Note A minus sign (-) for Current frame indicates reverse video playback.
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Graphics

In this section...
“Mark Tracked Objects” on page 2-24

“Annotate Video Files with Frame Numbers” on page 2-24

Mark Tracked Objects

This example tracks and marks objects at a train station and determines
which ones remain stationary. Abandoned objects in public areas concern
authorities because such objects can pose a security risk. Algorithms, such as
the one used in this demo, can be used to assist security officers monitoring
live surveillance video by directing their attention to a potential area of
interest.

You can find demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line. You can also launch
the Abandoned Object Detection demo model directly, by typing
videoabandonedobj on the MATLAB command line.

Annotate Video Files with Frame Numbers

You can use the vision.TextInserter System object in MATLAB, or

thelnsert Text block in a Simulink model, to overlay text on video streams.
In this Simulink model example, you add a running count of the number of
video frames to a video using the Insert Text block. The model contains the
From Multimedia File block to import the video into the Simulink model, a
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Frame Counter block to count the number of frames in the input video, and
two Video Viewer blocks to view the original and annotated videos.

You can open the example model by typing
ex_annotate_video_files_with_frame_numbers

on the MATLAB command line.

1 Run your model.

2 The model displays the original and annotated videos.

Bl video Viewer o |[= ][ =] | B video Viewerl
File Tools View Simulation Help o File Tools View
@ || O = S| B o0 - SNEA

"> @5 LAk

Paused [120x160 T=522 465 Paused
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Color Formatting

For this example, the color format for the video was set to Intensity, and
therefore the color value for the text was set to a scaled value. If instead, you
set the color format to RGB, then the text value must satisfy this format, and
requires a 3-element vector.

Inserting Text

Use the Insert Text block to annotate the video stream with a running frame
count. Set the block parameters as follows:

® Main pane, Text = [ 'Frame count' sprintf('\n') 'Source frame:
%d "]

¢ Main pane, Color value =1
® Main pane, Location [row, column] = [85 2]

* Font pane, Font face = LucindaTypewriterRegular

By setting the Text parameter to [ ' Frame count' sprintf('\n') 'Source
frame: %d'], you are asking the block to print Frame count on one line
and the Source frame: on a new line. Because you specified %d, an ANSI

C printf-style format specification, the Variables port appears on the block.
The block takes the port input in decimal form and substitutes this input for
the %d in the string. You used the Location [row, column] parameter to
specify where to print the text. In this case, the location is 85 rows down and
2 columns over from the top-left corner of the image.

Configuration Parameters
Set the configuration parameters. Open the Configuration dialog box by

selecting Configuration Parameters from the Simulation menu. Set the
parameters as follows:

¢ Solver pane, Stop time = inf

® Solver pane, Type = Fixed-step

¢ Solver pane, Solver = Discrete (no continuous states)



Registration and Stereo
Vision

e “Feature Detection, Extraction, and Matching” on page 3-2
* “Image Registration” on page 3-28

® “Stereo Vision” on page 3-32
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Feature Detection, Extraction, and Matching

In this section...

“Detect Edges in Images” on page 3-2
“Detect Lines in Images” on page 3-10
“Detect Corner Features in an Image ” on page 3-14

“Find Possible Point Matches Between Two Images” on page 3-15

“Measure an Angle Between Lines” on page 3-16

Detect Edges in Images

You can use the Edge Detection block to find the edges of objects in an image.
This block finds the pixel locations where the magnitude of the gradient of
intensity is larger than a threshold value. These locations typically occur at
the boundaries of objects. In this section, you use the Edge Detection block to
find the edges of rice grains in an intensity image:

1 Create a Simulink model, and add the blocks shown in the following
table. Or, start with the model containing the blocks by typing
ex_finding edges_blocks at the MATLAB command line.

Block Library Quantity

Image From File Computer Vision System Toolbox > 1
Sources

Edge Detection Computer Vision System Toolbox > 1
Analysis & Enhancement

Minimum Computer Vision System Toolbox > 2
Statistics

Maximum Computer Vision System Toolbox > 2
Statistics

Video Viewer Computer Vision System Toolbox > 4
Sinks
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Block Library Quantity
Subtract Simulink > Math Operations 2
Divide Simulink > Math Operations 2

2 Place the blocks so that your model resembles the following figure.

5] doc_finding_edges_blocks

File Edit WYiew Simulaton Format Tools Help

D dE| t 2R 422 »r =0 | [Nomal FllEsERS s R

Imags From Fils Edgs Dataction Video Viewerl
Video
1 Val + I Val = Image \:_:t_
~ L . L Views
Iz = Iz = *
— Subtract - Divide
Minimum Maxirmum YT
Vides Viewsr2
Ar
o Vel b iden
Val + I . L Image ,:.h"'"
_ [+ Idx B - Viewsar
Iz = Dlivide
— Subtracti Aaxi o
Minimum1 Maximum1
Video Viewer3
[100% |ode4s

Ready
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You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

3 Use the Image From File block to import your image. Set the parameters
as follows:

¢ File name to rice.png.

¢ Output data type to single.

4 Use the Edge Detection block to find the edges in the image. Set the block
parameters as follows:

¢ Output type =Binary image and gradient components

e Select the Edge thinning check box.

=] Function Block Parameters: Edge Detection x|

Edge Detection

Finds the edges in an input image using Sobel, Prewitt, Roberts, or Canny methods.

The block outputs a binary image, & matrix of Boolean values, where pixel values equal to 1 correspond to
edges. Alternatively, the block can output two gradient components of the image for the first three
methods,

Mair | Fixed-pointl

—Parameters
Method: ISDI:-EI ;I
Qutput type: IBinar*r' image and gradient components LI

™ User-defined threshold

Threshold scale factor:
(used to automatically calculate threshaold value)

|4

W Edae thinning

oK I Cancel Help Apply

The Edge Detection block convolves the input matrix with the Sobel kernel.
This calculates the gradient components of the image that correspond
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to the horizontal and vertical edge responses. The block outputs these
components at the Gh and Gv ports, respectively. Then the block performs
a thresholding operation on the gradient components to find the binary
image. The binary image is a matrix filled with 1s and 0s. The nonzero
elements of this matrix correspond to the edge pixels and the zero elements
correspond to the background pixels. The block outputs the binary image
at the Edge port.

5 View the original image using the Video Viewer block and the binary
image using the Video Viewerl block. Accept the default parameters for
both viewers.

6 The matrix values at the Gv and Gh output ports from of the Edge
Detection block are double-precision floating-point. These matrix values
need to be scaled between 0 and 1 in order to display them using the Video
Viewer blocks. This is done with the Statistics and Math Operation blocks.

7 Use the Minimum blocks to find the minimum value of Gv and Gh matrices.
Set the Mode parameters to Value for both of these blocks.

8 Use the Subtract blocks to subtract the minimum values from each element
of the Gv and Gh matrices. This process ensures that the minimum value
of these matrices is 0. Accept the default parameters.

9 Use the Maximum blocks to find the maximum value of the new Gv and Gh
matrices. Set the Mode parameters to Value for both of these blocks.

10 Use the Divide blocks to divide each element of the Gv and Gh matrices
by their maximum value. This normalization process ensures that these
matrices range between 0 and 1.Accept the default parameters.

11 View the gradient components of the image using the Video Viewer2 and
Video Viewer3 blocks. Accept the default parameters.

12 Connect the blocks as shown in the following figure, or type
ex_finding_edges_connected_blocks at the MATLAB command line
using a connected model.
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5] doc_finding_edges_connected_blocks
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13 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
¢ Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)
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¢ Diagnostics pane, Automatic solver parameter selection: = none

14 Run your model.

The Video Viewer window displays the original image. The Video Viewerl
window displays the edges of the rice grains in white and the background

in black.

=

File Tools WView Playback Help w
B O & | & &[]0 ~]
R L o

Resady | 256256 T=10.000

The Video Viewer2 window displays the intensity image of the vertical
gradient components of the image. You can see that the vertical edges of
the rice grains are darker and more well defined than the horizontal edges.
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The Video Viewer3 window displays the intensity image of the horizontal
gradient components of the image. In this image, the horizontal edges of
the rice grains are more well defined.
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15 Double-click the Edge Detection block and clear the Edge thinning check
box.

16 Run your model again.

Your model runs faster because the Edge Detection block is more efficient
when you clear the Edge thinning check box. However, the edges of rice
grains in the Video Viewer window are wider.
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You have now used the Edge Detection block to find the object boundaries in
an image. For more information on this block, see the Edge Detection block
reference page in the Computer Vision System Toolbox Reference.

Detect Lines in Images

Finding lines within images enables you to detect, measure, and recognize
objects. In this example, you use the Hough Transform, Find Local Maxima,
Edge Detectionand Hough Lines blocks to find the longest line in an image.

You can open the model for this example by typing

ex_finding_lines_connected_blocks
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at the MATLAB command line.

H‘u’iden Viewer | = ||_IEI__| 3 | u‘-ﬁden Viewerl

File Tools View Simulation Help ¥ | File Tools View
@ @ B | = =& | 6D 100% - 8 O ¢
D i 5 =D o
Ready 280272 T=0.000 Ready

The Video Viewer blocks display the original image, the image with all edges
found, and the image with the longest line annotated.

The Edge Detection block finds the edges in the intensity image. This process
improves the efficiency of the Hough Lines block by reducing the image area
over which the block searches for lines. The block also converts the image to a
binary image, which is the required input for the Hough Transform block.

For additional examples of the techniques used in this section, see the
following list of demos. You can open these demos by typing the demo titles
at the MATLAB command prompt:
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Demo MATLAB Simulink
model-based
Lane Departure videoldws vipldws

Warning System

Rotation Correction videorotationcorrectioniphough

You can find all demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line.

Setting Block Parameters

Hough The Hough Transform block computes the Hough

Transform matrix by transforming the input image into the
rho-theta parameter space. The block also outputs
the rho and theta values associated with the Hough
matrix. The parameters are set as follows:

¢ Theta resolution (radians) = pi/360

e Select the Output theta and rho values check

box.
Find Local The Find Local Maxima block finds the location of
Maxima the maximum value in the Hough matrix. The block

parameters are set as follows:

¢ Maximum number of local maxima = 1

¢ Input is Hough matrix spanning full theta
range
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Selector

Variable
Selector

Hough Lines

Draw Shapes

The Selector blocks separate the indices of the rho
and theta values, which the Find Local Maxima block
outputs at the Idx port. The rho and theta values
correspond to the maximum value in the Hough
matrix. The Selector blocks parameters are set as
follows:

* Number of input dimensions: 1
¢ Index mode = Zero-based
¢ Index Option = Index vector (port)

¢ Input port size =2

You can ground the other input of the Selector blocks,
but doing so is necessary.

The Variable Selector blocks index into the rho and
theta vectors and determine the rho and theta values
that correspond to the longest line in the original
image. The parameters of the Variable Selector blocks
are set as follows:

e Select = Columns

¢ Index mode = Zero-based

The Hough Lines block determines where the longest

line intersects the edges of the original image.

¢ Sine value computation method =
Trigonometric function

The Draw Shapes block draws a white line over the
longest line on the original image. The coordinates are
set to superimpose a line on the original image. The
block parameters are set as follows:

® Shape = Lines

e Border color = White
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Configuration Parameters
Set the configuration parameters. Open the Configuration dialog box by

selecting Configuration Parameters from the Simulation menu. Set the
parameters as follows:

® Solver pane, Stop time = 0

® Solver pane, Type = Fixed-step

e Solver pane, Solver = discrete (no continuous states)

® Solver pane, Fixed-step size (fundamental sample time): = 0.2

Detect Corner Features in an Image

Stabilizing a video that was captured from a jittery or moving platform is an
important application in computer vision. One way to stabilize a video is to
track a salient feature in the image and use this as an anchor point to cancel
out all perturbations relative to it. This example uses corner detection around
salient image features.

You can find demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line. You can also launch the Video
Stabilization Using Point Feature Matching demo model directly, by typing
videostabilize pm on the MATLAB command line.
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Find Possible Point Matches Between Two Images

Stabilizing a video that was captured from a jittery or moving platform is an
important application in computer vision. One way to stabilize a video is

to track a salient feature in the image and use this as an anchor point to
cancel out all perturbations relative to it. This procedure, however, must

be bootstrapped with knowledge of where such a salient feature lies in the
first video frame. In this example, we explore a method of video stabilization
that works without any such a priori knowledge. It instead automatically
searches for the "background plane" in a video sequence, and uses its observed
distortion to correct for camera motion.

You can launch this example, Video Stabilization Using Point Feature
Matching directly, by typing videostabilize pm on the MATLAB command
line.

Video mosaicking is the process of stitching video frames together to form a
comprehensive view of the scene. The resulting mosaic image is a compact
representation of the video data, which is often used in video compression
and surveillance applications. This example illustrates how to use the
CornerDetector, GeometricTransformEstimator, AlphaBlender, and the
GeometricTransformer System objects to create a mosaic image from a video
sequence. First, the example identifies the corners in the first reference frame
and second video frame. Then, it calculates the projective transformation
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matrix that best describes the transformation between corner positions in
these frames. Finally, the demo overlays the second image onto the first
image. The example repeats this process to create a mosaic image of the
video scene.
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You can launch this example, Video Mosaicking directly, by typing
videomosaicking on the MATLAB command line.

You can find demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line.

Measure an Angle Between Lines

The Hough Transform, Find Local Maxima, and Hough Lines blocks enable
you to find lines in images. With the Draw Shapes block, you can annotate
images. In the following example, you use these capabilities to draw lines on
the edges of two beams and measure the angle between them.

1 Create a new Simulink model, and add to it the blocks shown in the
following table.
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Block Library Quantity

Image From File Computer Vision System Toolbox > 1
Sources

Color Space Computer Vision System Toolbox > 1

Conversion Conversions

Edge Detection Computer Vision System Toolbox > 1
Analysis & Enhancement

Hough Transform | Computer Vision System Toolbox > 1
Transforms

Find Local Computer Vision System Toolbox > 1

Maxima Statistics

Draw Shapes Computer Vision System Toolbox > Text | 1
& Graphics

Video Viewer Computer Vision System Toolbox > Sinks | 3

Hough Lines Computer Vision System Toolbox > 1
Transforms

Submatrix DSP System Toolbox > Math Functions | 4
> Matrices and Linear Algebra > Matrix
Operations

Terminator Simulink > Sinks 1

Selector Simulink > Signal Routing 4

MATLAB Simulink > User-Defined Functions 1

Function

Display Simulink > Sinks 1

2 Position the blocks as shown in the following figure.
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3 Use the Image From File block to import an image into the Simulink model.

Set the parameters as follows:

¢ File name = gantrycrane.png

* Sample time = 1
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4 Use the Color Space Conversion block to convert the RGB image into the
Y’CbCr color space. You perform this conversion to separate the luma
information from the color information. Accept the default parameters.

Note In this example, you segment the image using a thresholding
operation that performs best on the Cb channel of the Y'CbCr color space.

5 Use the Selector and Selectorl blocks to separate the Y’ (luminance) and
Cb (chrominance) components from the main signal.

The Selector block separates the Y’ component from the entire signal. Set
its block parameters as follows:

¢ Number of input dimensions = 3

¢ Index mode = Zero-based

o1

= Index Option = Select all
° 2

= Index Option = Select all
* 3

Index Option = Index vector (dialog)

Index = 1

The Selectorl block separates the Cb component from the entire signal.
Set its block parameters as follows:

¢ Number of input dimensions = 3
¢ Index mode = Zero-based

1

Index Option = Select all

Index Option = Select all

3-19



3 Registration and Stereo Vision

3
= Index Option = Index vector (dialog)
- Index =2
6 Use the Submatrix and Submatrix1 blocks to crop the Y’ and Cb matrices

to a particular region of interest (ROI). This ROI contains two beams that
are at an angle to each other. Set the parameters as follows:

e Starting row = Index

¢ Starting row index = 66

* Ending row = Index

¢* Ending row index = 150

¢ Starting column = Index

¢ Starting column index = 325
* Ending column = Index

* Ending column index = 400

7 Use the Edge Detection block to find the edges in the Cb portion of the
image. This block outputs a binary image. Set the Threshold scale
factor parameter to 1.

8 Use the Hough Transform block to calculate the Hough matrix, which gives
you an indication of the presence of lines in an image. Select the Output
theta and rho values check box as shown in the following figure.

Note In step 11, you find the theta and rho values that correspond to the
peaks in the Hough matrix.
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=] Function Block Parameters: Hough Transform x|

—Hough Transform

Implements the Hough Transform to detect lines.
The block generates a parameter space matrix using the following equation:
rho = x*cos(theta) + y*sin(theta).
The block outputs this matrix at the Hough paort. The rows and columns of this matrix correspond tao the

rho and theta values, respectively, Peak values in this matrix represent potential straight lines in the
input image.

Main Fixed-point I

—Parameters

Theta resolution {radians): Ipi,r'IBEI

Rho resolution: I 1

¥ Cutput theta and rho values

Cutput data type: Iu:h:uul:ule ;I

oK Cancel Help | Apply |

9 Use the Find Local Maxima block to find the peak values in the Hough
matrix. These values represent potential lines in the input image. Set
the parameters as follows:

¢ Neighborhood size = [11 11]

¢ Input is Hough matrix spanning full theta range = selected

Because you are expecting two lines, leave the Maximum number of
local maxima (N) parameter set to 2, and connect the Count port to the
Terminator block.
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10 Use the Submatrix2 block to find the indices that correspond to the theta

12

values of the two peak values in the Hough matrix. Set the parameters as
follows:

* Starting row = Index

® Starting row index =2

* Ending row = Index

¢ Ending row index =2

The Idx port of the Find Local Maxima block outputs a matrix whose second
row represents the zero-based indices of the theta values that correspond
to the peaks in the Hough matrix. Now that you have these indices, you

can use a Selector block to extract the corresponding theta values from the
vector output of the Hough Transform block.

Use the Submatrix3 block to find the indices that correspond to the rho
values of the two peak values in the Hough matrix. Set the parameters as
follows:

¢ Ending row = Index

¢ Ending row index = 1

The Idx port of the Find Local Maxima block outputs a matrix whose first
row represents the zero-based indices of the rho values that correspond to
the peaks in the Hough matrix. Now that you have these indices, you can

use a Selector block to extract the corresponding rho values from the vector
output of the Hough Transform block.

Use the Selector2 and Selector3 blocks to find the theta and rho values
that correspond to the peaks in the Hough matrix. These values, output
by the Hough Transform block, are located at the indices output by the
Submatrix2 and Submatrix3 blocks. Set both block parameters as follows:

* Index mode = Zero-based
1
= Index Option = Index vector (port)

® Input port size = -1
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You set the Index mode to Zero-based because the Find Local Maxima
block outputs zero-based indices at the Idx port.

13 Use the Hough Lines block to find the Cartesian coordinates of lines that
are described by rho and theta pairs. Set the Sine value computation
method parameter to Trigonometric function.

14 Use the Draw Shapes block to draw the lines on the luminance portion of
the ROI. Set the parameters as follows:

¢ Shape = Lines
e Border color = White

15 Use the MATLAB Function block to calculate the angle between the two
lines. Copy and paste the following code into the block:

function angle = compute_angle(theta)

%sCompute the angle value in degrees
angle = abs(theta(1)-theta(2))*180/pi;
%Always return an angle value less than 90 degrees
if (angle>90)
angle = 180-angle;
end

16 Use the Display block to view the angle between the two lines. Accept the
default parameters.

17 Use the Video Viewer blocks to view the original image, the ROI, and the
annotated ROI. Accept the default parameters.

18 Connect the blocks as shown in the following figure.
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19 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0

¢ Solver pane, Type = Fixed-step
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® Solver pane, Solver = Discrete (no continuous states)
20 Run the model.

The Video Viewer window displays the original image.
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The Video Viewerl window displays the ROI where two beams intersect.
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Video Viewerl

The Video Viewer2 window displays the ROI that has been annotated with
two white lines.
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The Display block shows a value of 58, which is the angle in degrees
between the two lines on the annotated ROL.

You have now annotated an image with two lines and measured the angle
between them. For additional information, see the Hough Transform, Find
Local Maxima, Hough Lines, and Draw Shapes block reference pages.
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Image Registration

In this section...

“Automatically Determine Geometric Transform for Image Registration”
on page 3-28

“Transform Images and Display Registration Results” on page 3-29

“Remove the Effect of Camera Motion from a Video Stream.” on page 3-31

Automatically Determine Geometric Transform for
Image Registration

Stabilizing a video that was captured from a jittery or moving platform is an
important application in computer vision. One way to stabilize a video is

to track a salient feature in the image and use this as an anchor point to
cancel out all perturbations relative to it. This procedure, however, must

be bootstrapped with knowledge of where such a salient feature lies in the
first video frame. In this example, we explore a method of video stabilization
that works without any such a priori knowledge. It instead automatically
searches for the "background plane" in a video sequence, and uses its observed
distortion to correct for camera motion.




Image Registration

This stabilization algorithm involves two steps. First, we determine the affine
image transformations between all neighboring frames of a video sequence
using a Random Sampling and Consensus (RANSAC) [1] procedure applied to
point correspondences between two images. Second, we warp the video frames
to achieve a stabilized video. We use System objects in the Computer Vision
System Toolbox™, both for the algorithm and for display.

You can launch this example, Video Stabilization Using Point Feature
Matching directly, by typing videostabilize pm on the MATLAB command
line.

Transform Images and Display Registration Results

Rectification is the process of transforming stereo images, such that the
corresponding points have the same row coordinates in the two images. It is a
useful procedure in stereo vision, as the 2-D stereo correspondence problem is
reduced to a 1-D problem when rectified image pairs are used.

The Image Rectification demo automatically registers and rectifies stereo

images. This example detects corners in stereo images, matches the corners,
computes the fundamental matrix, and then rectifies the images.
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You can find demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line. You can also launch the Image
Rectification demo model directly, by typing videorectification on the
MATLAB command line.
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Remove the Effect of Camera Motion from a Video
Stream.

The video stabilization demo tracks a license plate of a vehicle while reducing
the effect of camera motion from a video stream.

In the first video frame, the model defines the target to track. In this case, it
is the back of a car and the license plate. It also establishes a dynamic search
region, where the last known target location determines the position.

You can find demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line. You can launch the Video
Stabilization model directly by typing vipstabilize on the MATLAB
command line.
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Stereo Vision

In this section...

“Compute Disparity Depth Map” on page 3-32
“Find Fundamental Matrix Describing Epipolar Geometry” on page 3-33
“Rectify Stereo Images” on page 3-35

Compute Disparity Depth Map

Stereo vision is the process of recovering depth from camera images by
comparing two or more views of the same scene. Simple, binocular stereo uses
only two images, typically taken with parallel cameras that were separated
by a horizontal distance known as the "baseline." The output of the stereo
computation is a disparity map (which is translatable to a range image) which
tells how far each point in the physical scene was from the camera.

In this example, we use MATLAB® and the Computer Vision System
Toolbox™ to compute the depth map between two rectified stereo images.
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Color composite (right=red, left=cyan)

You can find demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line. You can also launch the
Stereo Vision demo model directly, by typing videostereo on the MATLAB
command line.

Find Fundamental Matrix Describing Epipolar
Geometry

In computer vision, the fundamental matrix is a 3X3 matrix which relates
corresponding points in stereo images. When two cameras view a 3D scene
from two distinct positions, there are a number of geometric relations
between the 3D points and their projections onto the 2D images that lead to
constraints between the image points. Two images of the same scene are
related by epipolar geometry.
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This example takes two stereo images, computes the fundamental matrix from
their corresponding points, displays the original stereo images, corresponding
points, and epipolar lines for this and for the rectified images.

Load stereo images and cnovert them to double precision:

% Load the stereo images and convert them to double precision.
I1 imread('yellowstone_left.png');
I2 imread('yellowstone_right.png');
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% Load the points which are already matched.
load yellowstone_matched_points;

% Compute the fundamental matrix from the corresponding points.
f= estimateFundamentalMatrix(matched_points1, matched_points2,...
‘Method', 'Norm8Point');

% Display the original stereo images, corresponding points, and

% epipolar lines.

cvexShowStereoImages('Original image 1', 'Original image 2',
I1, I2, matched_points1, matched_points2, f);

% Compute the rectification transformations.
[t1, t2] = estimateUncalibratedRectification(f,...
matched _pointsi1, matched _points2, size(I2));

if iskEpipoleInImage(f, size(I1)) || isEpipoleInImage(f', size(I2))
error([ 'For the rectification to succeed, the epipoles must be',..
‘outside the images.']);
end

% Rectify the stereo images using the projective transformations t1 :
% t2 and display the resulting images, corresponding points, and
% epipolar lines.
cvexShowStereoImages('Rectified image 1', 'Rectified image 2',...
I1, I2, matched_points1, matched_points2, f, t1, t2);

You can find demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line.

Rectify Stereo Images

Rectification is the process of transforming stereo images, such that the
corresponding points have the same row coordinates in the two images. It is a
useful procedure in stereo vision, as the 2-D stereo correspondence problem is
reduced to a 1-D problem when rectified image pairs are used.
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The Image Rectification demo automatically registers and rectifies stereo
images. This example detects corners in stereo images, matches the corners,
computes the fundamental matrix, and then rectifies the images.

Inlie
Inlie

T

You can find demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line. You can also launch the Image
Rectification demo model directly, by typing videorectification on the
MATLAB command line.
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Tracking

® “Detect and Track Moving Objects Using Gaussian Mixture Models” on
page 4-2

* “Video Mosaicking” on page 4-3
® “Track an Object Using Correlation” on page 4-4

® “Create a Panoramic Scene” on page 4-12
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Detect and Track Moving Objects Using Gaussian Mixture

Models

This example illustrates how to detect cars in a video sequence using
foreground detection based on Gaussian mixture models (GMMs). After
foreground detection, the example processes the binary foreground images
using blob analysis. Finally, bounding boxes are drawn around the detected
cars.

You can find demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line. You can also launch the
Tracking Cars Using Gaussian Mixture Models demo model directly, by
typing videotrafficgmm at the MATLAB command line.
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Video Mosaicking

Video mosaicking is the process of stitching video frames together to form a
comprehensive view of the scene. The resulting mosaic image is a compact
representation of the video data, which is often used in video compression
and surveillance applications.

You can find demos for the Computer Vision System Toolbox by typing
visiondemos at the MATLAB command line. You can also launch the Video
Mosaicking demo model directly, by typing videomosaicking at the MATLAB
command line.
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Track an Object Using Correlation

In this example, you use the 2-D Correlation, Maximum, and Draw Shapes
blocks to find and indicate the location of a sculpture in each video frame:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity
Read Binary File Computer Vision System 1

Toolbox > Sources
Image Data Type Computer Vision System 1
Conversion Toolbox > Conversions
Image From File Computer Vision System 1

Toolbox > Sources

2-D Correlation Computer Vision System 1
Toolbox > Statistics

Maximum Computer Vision System 1
Toolbox > Statistics

Draw Shapes Computer Vision System 1
Toolbox > Text & Graphics

Video Viewer Computer Vision System 1
Toolbox > Sinks

Data Type Conversion | Simulink > Signal Attributes 1

Constant Simulink > Sources 1

Mux Simulink > Signal Routing 1

2 Position the blocks as shown in the following figure.
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You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

3 Use the Read Binary File block to import a binary file into the model. Set
the block parameters as follows:

¢ File name = cat_video.bin
¢ Four character code = GREY
¢ Number of times to play file = inf

* Sample time = 1/30
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E! Source Block Parameters: Read Binary File |

—FRead Binary File

Fiead binary video data from file in the specified format,

—Parameters

File name: Ical_video.bin Browsze. . |

Wideo fnrmat:l Faour character codes

=
=

Four character code: I GREY

Frame size Flows:|12ﬂ Cals: |160

Line nrdering:l Top line first LI

MHumber of times to play file: Iinf

[~ Dutput end-of-file indicator

Sample time: |1,/30

Cancel Help

4 Use the Image Data Type Conversion block to convert the data type of the
video to single-precision floating point. Accept the default parameter.

5 Use the Image From File block to import the image of the cat sculpture,
which is the object you want to track. Set the block parameters as follows:

® Main pane, File name = cat_target.png

¢ Data Types pane, Output data type = single

6 Use the 2-D Correlation block to determine the portion of each video frame

that best matches the image of the cat sculpture. Set the block parameters
as follows:

® Qutput size = Valid
e Select the Normalized output check box.
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E! Function Block Parameters: 2-D Correlation x|

—2-D Correlation

Performs bwo-dimenzional cross-correlation between bwo inputs.

Uze the Dutput size parameter to specify the dimensions of the output. Aszume that
the input at part 11 has dimensions [Ma, Ma) and the input at part 12 haz dimensions
[Mb, Mb]. If you choose Full, the output iz the full bwo-dimensional crozz-corelation
with dimenzions [Ma+hb-1, Ma+Mb-1]. If vou choose Same as input port |1, the output
iz the central part of the crosz-carrelation with the zame dimenzions as the input at
port 1. If you choose Yalid, the output iz only those parts of the cross-correlation that
are computed without the zero-padded edaes of any input. Thiz output has
dimenzions [Ma-tb+1, Ma-Mb+1].

Y'ou can normalize the output only when the input iz floating paint.

Main IFiHed-pnint I

Farameters
Cutput size:l *alid ;I
[ Momalized output

0K | Cancel Apply |

Because you chose Valid for the Output size parameter, the block
outputs only those parts of the correlation that are computed without the
zero-padded edges of any input.

7 Use the Maximum block to find the index of the maximum value in each
input matrix. Set the Mode parameter to Index.

The block outputs the zero-based location of the maximum value as a
two-element vector of 32-bit unsigned integers at the Idx port.

8 Use the Data Type Conversion block to change the index values from 32-bit
unsigned integers to single-precision floating-point values. Set the Output
data type parameter to single.
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4 Motion Analysis and Tracking

9 Use the Constant block to define the size of the image of the cat sculpture.
Set the Constant value parameter to single([41 41]).

10 Use the Mux block to concatenate the location of the maximum value and
the size of the image of the cat sculpture into a single vector. You use this

vector to define a rectangular region of interest (ROI) that you pass to the
Draw Shapes block.

11 Use the Draw Shapes block to draw a rectangle around the portion of each
video frame that best matches the image of the cat sculpture. Accept the
default parameters.

) Function Block Parameters: Draw Shapes x|

— Diraws Shape

Draw multiple rectangles, lines, polygons, or circles on images by overwriting pixel
walues,

|1ge the Ptz port to zpecify the appropriate shape coordinates. v'ou can define the
color or intengity value of the shape's border, You can alzo chooge o fill pour shape
and specify itz opacity,

— Parameter.

Shape: IHectangles :l

The input ta the Pts port must be a four-by-M matriz where each column iz of the farm
[r & height width] and specifies a different rectangle.

[~ Fill shapes

Barder value: IBIack :I
Draw shapes in: IEntire image :I
|mage gignal: IEIne multidimenzional zignal j

QK I Cancel Help | Apply |

12 Use the Video Viewer block to display the video stream with the ROI
displayed on it. Accept the default parameters.

The Video Viewer block automatically displays the video in the Video
Viewer window when you run the model. Because the image is represented



Track an Obiject Using Correlation

by single-precision floating-point values, a value of 0 corresponds to black
and a value of 1 corresponds to white.

13 Connect the blocks as shown in the following figure.

Fluntitled * =1olx]
File Edit “iew Simulation Format Tools Help
DEE&| L ER| e 4 (2 r afon |imd -~ BEBes pEE®
. . = Convert Image
cat_video. bin " L 1 singke
Read Binany Fike Image Data. Type
Conmversion
Bl
2-DXCORR I Iz
4|—>|2 Image
cat_target. png Image 5.0 Co e =t [ —— Data Type Sonversion Draw Wideo
-LsamRiston Rectangles P Image Wizwer
o Fis
Image From Fike
single([4141]) Drw Shapes Video Viewer
Constant
Ready [100% [ [ |ode4s 4

14 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

¢ Solver pane, Stop time = inf
® Solver pane, Type = Fixed-step

¢ Solver pane, Solver = Discrete (no continuous states)
15 Run the simulation.

The video is displayed in the Video Viewer window and a rectangular
box appears around the cat sculpture. To view the video at its true size,
right-click the window and select Set Display To True Size.
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_ioix

File Tools View Playback Help u
O R []]00%
me @

Pauzed 1120160 T=0.200

As the video plays, you can watch the rectangular ROI follow the sculpture
as it moves.
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) Video Viewer

File Tools View Playback Help

=101 %]

N

B O®|Qam| =

100%

=@

Ready 11201 60

T=4 B&7

In this example, you used the 2-D Correlation, 2-D Maximum, and Draw
Shapes blocks to track the motion of an object in a video stream. For more
information about these blocks, see the 2-D Correlation, Maximum, and Draw

Shapes block reference pages.

Note This example model does not provide an indication of whether or not
the sculpture is present in each video frame. For an example of this type of
model, type vippattern at the MATLAB command prompt.
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4 Motion Analysis and Tracking

Create a Panoramic Scene

The motion estimation subsystem for the Panorama Creation demo uses
template matching. This model uses the Template Matching block to estimate
the motion between consecutive video frames. It then computes the motion
vector of a particular block in the current frame with respect to the previous
frame. The model uses this motion vector to align consecutive frames of the
video to form a panoramic picture.

You can find demos for the Computer Vision System Toolbox by typing
visiondemos on the MATLAB command line. You can launch the Panorama
model directly by typing vippanorama on the MATLAB command line.
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Geometric Transformations

¢ “Rotate an Image” on page 5-2
e “Resize an Image” on page 5-9
® “Crop an Image” on page 5-15
¢ “Interpolation Methods” on page 5-21

e “Automatically Determine Geometric Transform for Image Registration”
on page 5-25



5 Geometric Transformations

Rotate an Image

You can use the Rotate block to rotate your image or video stream by a
specified angle. In this example, you learn how to use the Rotate block to
continuously rotate an image:

1 Define an RGB image in the MATLAB workspace. At the MATLAB
command prompt, type

I = checker_board;

I is a 100-by-100-by-3 array of double-precision values. Each plane of the
array represents the red, green, or blue color values of the image.

2 To view the image this matrix represents, at the MATLAB command
prompt, type

imshow(I)

) Figure SI=TEY

FEVITTiDe Wik w

D& >

3 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity
Image From Computer Vision System Toolbox | 1
Workspace > Sources
Rotate Computer Vision System Toolbox | 1

> Geometric Transformations




Rotate an Image

Block Library Quantity
Video Viewer Computer Vision System Toolbox | 2
> Sinks
Gain Simulink > Math Operations 1
Display DSP System Toolbox > Signal 1
Processing Sinks
Counter DSP System Toolbox > Signal 1
Management > Switches and
Counters

4 Position the blocks as shown in the following figure.

File Edit Wiew

Simulation Format Tools

=10l x|

DEHE| BR[| 9

b = |1:.:

I Momal

chedwer b

card{10} Image

Ready

Image From Wordspace

Rst

Cnt [
Count
Up )l>}
Hit [

Counter

Raotate -

Rotate

Disglay

100%:

|ode4s
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5-4

You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

5 Use the Image From Workspace block to import the RGB image from the
MATLAB workspace. On the Main pane, set the Value parameter to
I.Each plane of the array represents the red, green, or blue color values
of the image.

6 Use the Video Viewer block to display the original image. Accept the
default parameters.

The Video Viewer block automatically displays the original image in
the Video Viewer window when you run the model. Because the image
1s represented by double-precision floating-point values, a value of 0
corresponds to black and a value of 1 corresponds to white.

7 Use the Rotate block to rotate the image. Set the block parameters as
follows:

¢ Rotation angle source = Input port

¢ Sine value computation method = Trigonometric function



Rotate an Image

E Function Block Parameters: Rotate x|
—Rotate

Rotates an image by an angle in radians. You can spedfy this angle using the block parameters dialog box or
input port Angle,

IJse the Qutput size parameter to determine the size of the output. If you select Expanded to fit rotated input
image, the block outputs a matrix that contains all the rotated image values and zeros elsewhere, If you select
Same as input image, the block outputs a matrix that contains the middle part of the rotated image and zeros
elsewhere, As a result, the edges of the rotated image might be cropped.

When specifying the rotation angle using the Angle part, the maximum angle value should be greater than 0 but
less than or equal to pi radians.

Mairi | Data Types I

—Parameters
CQutput size: IExpanded to fit rotated input image ;I
Rotation angle source: ISpecify via dialog LI

Angle (radians): Ipifﬁ

Sine value computation method: ITabIE lookup LI

Backaground fill value: IEI

Interpolation method: IBiIinear LI

oK I Cancel Help Apply

The Angle port appears on the block. You use this port to input a steadily
increasing angle. Setting the Output size parameter to Expanded to fit
rotated input image ensures that the block does not crop the output.

8 Use the Video Viewerl block to display the rotating image. Accept the
default parameters.

9 Use the Counter block to create a steadily increasing angle. Set the block
parameters as follows:

¢ Count event = Free running
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5 Geometric Transformations

* Counter size = 16 bits

® OQutput = Count

® (Clear the Reset input check box.
* Sample time = 1/30

The Counter block counts upward until it reaches the maximum value
that can be represented by 16 bits. Then, it starts again at zero. You can
view its output value on the Display block while the simulation is running.
The Counter block’s Count data type parameter enables you to specify
it’s output data type.

10 Use the Gain block to convert the output of the Counter block from degrees
to radians. Set the Gain parameter to pi/180.

11 Connect the blocks as shown in the following figure.

-l

File Edit View Simulation Format Tools Help

DEE@&S| LER|c 492 » =fioo | [imd | 5 g

| - Wideo
= 9= viewer

Wideo Viewsr

Irnage

1_!'
i

Irmage Fmorn Workspace Wideo

-
- Irage Viewer
Wideo Viewarl
Up &nt
Gain Dri=p ey
Countar
Ready 100% |ode4s A
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Rotate an Image

12 Set the configuration parameters. Open the Configuration dialog box by

selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time = inf
® Solver pane, Type = Fixed-step
® Solver pane, Solver = Discrete (no continuous states)

13 Run the model.

The original image appears in the Video Viewer window.

RI=E
|

File Tools Wiew Playback Help
EIEEIEENIEES
R e

Ready RGE100x100  T=10.000

The rotating image appears in the Video Viewerl window.
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=

File Tools WView Playback Help o
B O ® & [0 ~]
C e s

Feady RGE142x142  T=10.000

In this example, you used the Rotate block to continuously rotate your image.
For more information about this block, see the Rotate block reference page
in the Computer Vision System Toolbox Reference. For more information
about other geometric transformation blocks, see the Resize and Shear block
reference pages.

Note If you are on a Windows operating system, you can replace the Video
Viewer block with the To Video Display block, which supports code generation.
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Resize an Image

You can use the Resize block to change the size of your image or video stream.
In this example, you learn how to use the Resize block to reduce the size
of an image:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity
Image From File Computer Vision System Toolbox | 1
> Sources
Resize Computer Vision System Toolbox | 1
> Geometric Transformations
Video Viewer Computer Vision System Toolbox | 2
> Sinks

2 Position the blocks as shown in the following figure.
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File Edit View

Simulation Format Tools

Help

=101 %]

D BES s e T2

b = I1E.E IN:::rmaI

Ready

i J
pERpers. png Imzags b Resize Image Visws
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Image From File Wideo Viewsrt
Video
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VIEWE
Video Views
|100% | g5

v

3 Use the Image From File block to import the intensity image. Set the File
name parameter to moon.tif. The tif file is a 537-by-358 matrix of 8-bit

unsigned integer values.

4 Use the Video Viewer block to display the original image. Accept the
default parameters.

The Video Viewer block automatically displays the original image in the
Video Viewer window when you run the model.

5 Use the Resize block to shrink the image. Set the Resize factor in %
parameter to 50.



Resize an Image

E Function Block Parameters: Resize

— Resize
Change the size of an image or a region of interest within an image.

|Uze the Specify parameter to designate the parameters you want to use to resize your
imaage. Y'ou can specify a zcalar percentage that iz applied to bath rows and calumns,
ar Yol can specify a bwo-element vector to scale the rows and columnz differently.
'ou can specify the number of roves and/or columis pou want your output image to
have, and you can prezerve of change the image's aspect ratio.

|Uze the Interpolation method parameter b specify the tupe of interpolation performed
by the block when it iz resizing a image. If you zelect the Perfarm antialiazing when
rezize factor is between 0 and 1 check box, the block perfarms lowpas: filkering on
the input image befare shrinking it.

M ain | Firned-point

— Parameter.

Specify; IEIutput zize gz a percentage of input size ;I

Resize factor in 22 IED

Interpolation method: IEiIinear LI

¥ Perform antialiazing when resize factor is between 0 and 100

ok I Cancel Help | Apply

The Resize block shrinks the image to half its original size.

6 Use the Video Viewerl block to display the modified image. Accept the

default parameters.

7 Connect the blocks as shown in the following figure.
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=

File Edit View Simulaton Format Tools Help

D|ﬁﬂ§|éﬁé|<}==§~{r|ﬂ@ PIIE Nomal

moon. tif Image = Resize | Image "-:ilf._E—:
Fesize
Image From File Y E—
L p{image /5=
Wideo Views
Ready |100% | | [FixedstepDiscrete

8 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step
® Solver pane, Solver = Discrete (no continuous states)

9 Run the model.

The original image appears in the Video Viewer window.




Resize an Image

il x]

File Tools View Playback Help o
B | @By | ® &Y [w0% ~|
I L =2

Ready 537358 T=0.000

The reduced image appears in the Video Viewerl window.
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_lnix

File Tools View Playback Help ~
®|08 (@0 @ -
C I i =

Resady | 269179 T=0.000

In this example, you used the Resize block to shrink an image. For more
information about this block, see the Resize block reference page. For more
information about other geometric transformation blocks, see the Rotate,
Shear, and Translate block reference pages.
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Crop an Image

You can use the Selector block to crop your image or video stream. In this
example, you learn how to use the Selector block to trim an image down to a
particular region of interest:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity
Image From File Computer Vision System Toolbox 1
> Sources
Video Viewer Computer Vision System Toolbox | 2
> Sinks
Selector Simulink > Signal Routing 1

2 Position the blocks as shown in the following figure.
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3 Use the Image From File block to import the intensity image. Set the File
name parameter to coins.png. The image is a 246-by-300 matrix of 8-bit
unsigned integer values.

4 Use the Video Viewer block to display the original image. Accept the
default parameters.

The Video Viewer block automatically displays the original image in the
Video Viewer window when you run the model.

5 Use the Selector block to crop the image. Set the block parameters as
follows:
e Number of input dimensions = 2
e 1
= Index Option = Starting index (dialog)
- Index =140



Crop an Image

- Output Size =70
e 2
= Index Option = Starting index (dialog)
- Index =200
= Output Size = 70

E! Function Block Parameters: Selector x|

— Selector

Select or reorder specified elements of a multidimengional input signal. The index to each element iz

identified from an input port or this dialog. 'ou can chooze the indesing method for each dimenzion by
uzing the "Index Option'' parameter.

— Parameter

MHumber of input dirmensions: |2

Index miode: IDne-based LI
Index Option Index Output Size |

1 |Starting index [dialog) ;I 140 Rl
2_ Starting index [dialog) :I 200 70

Sample time [-1 far inherited]: I-'I

Ok, I Cancel Help Spply

The Selector block starts at row 140 and column 200 of the image and
outputs the next 70 rows and columns of the image.

6 Use the Video Viewerl block to display the cropped image.

The Video Viewerl block automatically displays the modified image in the
Video Viewer window when you run the model.

7 Connect the blocks as shown in the following figure.
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8 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

9 Run the model.

The original image appears in the Video Viewer window.



Crop an Image

) Video Viewer - 10| x|
File Tools View Playback Help ﬂ
BRI e
=@

Ready [ 246300 T=0.000

The cropped image appears in the Video Viewer window. The following
image is shown at its true size.
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R
File Tools View Playback Help "
B OB & & |
=@

Reacy 7070 T=0.000

In this example, you used the Selector block to crop an image. For more
information about the Selector block, see the Simulink documentation. For
information about the imcrop function, see the Image Processing Toolbox
documentation.
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Interpolation Methods

In this section...

“Nearest Neighbor Interpolation” on page 5-21
“Bilinear Interpolation” on page 5-22

“Bicubic Interpolation” on page 5-23

Nearest Neighbor Interpolation

For nearest neighbor interpolation, the block uses the value of nearby
translated pixel values for the output pixel values.

For example, suppose this matrix,

1
4
7

o Ot N
© O W

represents your input image. You want to translate this image 1.7 pixels in
the positive horizontal direction using nearest neighbor interpolation. The

Translate block’s nearest neighbor interpolation algorithm is illustrated by
the following steps:

1 Zero pad the input matrix and translate it by 1.7 pixels to the right.

Translated zero-padded matrix

0
0
0

0 2 1 3 2 0 0
0 5 4 6 5 0
0 8 79 8§ 0 0

A
\4

1
4
7

Original zero-padded matrix

1.7 pixels
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2 Create the output matrix by replacing each input pixel value with the
translated value nearest to it. The result is the following matrix:

00123
0 0 456
007 89

Note You wanted to translate the image by 1.7 pixels, but this method
translated the image by 2 pixels. Nearest neighbor interpolation is
computationally efficient but not as accurate as bilinear or bicubic
interpolation.

Bilinear Interpolation

For bilinear interpolation, the block uses the weighted average of two
translated pixel values for each output pixel value.

For example, suppose this matrix,

1
4
7

@ Ot N
© O W

represents your input image. You want to translate this image 0.5 pixel in
the positive horizontal direction using bilinear interpolation. The Translate
block’s bilinear interpolation algorithm is illustrated by the following steps:

1 Zero pad the input matrix and translate it by 0.5 pixel to the right.
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Translated zero-padded matrix

|

0 1 1 2 2 3 3 0 0
0 4 4 5 5 6 6 0 0
0 7 7 8 8 9 9 0 0

—>

!

Original zero-padded matrix 0.5 pixel

2 Create the output matrix by replacing each input pixel value with the
weighted average of the translated values on either side. The result is
the following matrix where the output matrix has one more column than
the input matrix:

05 15 25 15
2 45 55 3
35 75 85 45

Bicubic Interpolation

For bicubic interpolation, the block uses the weighted average of four
translated pixel values for each output pixel value.

For example, suppose this matrix,

1
4
7

@ Ot N
© O W

represents your input image. You want to translate this image 0.5 pixel in
the positive horizontal direction using bicubic interpolation. The Translate
block’s bicubic interpolation algorithm is illustrated by the following steps:

1 Zero pad the input matrix and translate it by 0.5 pixel to the right.
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Translated zero-padded matrix

!

0 0 0 1 1 2 2 3 3 0 0 0
0 0 0 4 4 5 5 6 6 0 0 0
0 0 0 7 7 8 8 9 9 0 0 0

Original zero-padded matrix

0.5 pixel

2 Create the output matrix by replacing each input pixel value with the
weighted average of the two translated values on either side. The result is
the following matrix where the output matrix has one more column than
the input matrix:

0.375 1.5 3 1.625
1.875 4.875 6.375 3.125
3.375 8.25 9.75 4.625



Automatically Determine Geometric Transform for Image Registration

Automatically Determine Geometric Transform for Image
Registration

Stabilizing a video that was captured from a jittery or moving platform is an
important application in computer vision. One way to stabilize a video is

to track a salient feature in the image and use this as an anchor point to
cancel out all perturbations relative to it. This procedure, however, must

be bootstrapped with knowledge of where such a salient feature lies in the
first video frame. In this example, we explore a method of video stabilization
that works without any such a priori knowledge. It instead automatically
searches for the "background plane" in a video sequence, and uses its observed
distortion to correct for camera motion.

This stabilization algorithm involves two steps. First, we determine the affine
image transformations between all neighboring frames of a video sequence
using a Random Sampling and Consensus (RANSAC) [1] procedure applied to
point correspondences between two images. Second, we warp the video frames
to achieve a stabilized video. We use System objects in the Computer Vision
System Toolbox™, both for the algorithm and for display.

You can launch this example, Video Stabilization Using Point Feature

Matching directly, by typing videostabilize pm on the MATLAB command
line.
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Filters, Transforms, and
Enhancements

e “Adjust the Contrast of Intensity Images” on page 6-2

e “Adjust the Contrast of Color Images” on page 6-8

® “Remove Periodic Noise from a Video” on page 6-14

* “Remove Salt and Pepper Noise from Images” on page 6-23

e “Sharpen an Image” on page 6-30
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6-2

Adjust the Contrast of Intensity Images

This example shows you how to modify the contrast in two intensity images
using the Contrast Adjustment and Histogram Equalization blocks.

1 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity
Image From File Computer Vision System Toolbox > 2
Sources

Contrast Computer Vision System Toolbox > 1
Adjustment Analysis & Enhancement

Histogram Computer Vision System Toolbox > 1
Equalization Analysis & Enhancement

Video Viewer Computer Vision System Toolbox > 4

Sinks

2 Place the blocks so that your model resembles the following figure.
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3 Use the Image From File block to import the first image into the Simulink
model. Set the File name parameter to pout.tif.

4 Use the Image From Filel block to import the second image into the
Simulink model. Set the File name parameter to tire.tif.

5 Use the Contrast Adjustment block to modify the contrast in pout.tif.
Set the Adjust pixel values from parameter to Range determined by
saturating outlier pixels, as shown in the following figure.
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=1 Function Block Parameters: Contrast Adjustment

—Contrast Adjustment

Adjusts the contrast of an image by linearly scaling the pixel values between upper and lower limits,
Pixel values that are above or below this range are saturated to the upper or lower limit values,
respectively,

Main Fixed-point I

—Parameters

Adjust pixel values from: IRangE determined by saturating outlier pixels ;I

Percentage of pixels to saturate [low high] (in %): |[1 1]

¥ Specify number of histogram bins {used to calculate the range when outliers are eliminated)

Mumber of histogram bins: I 256

Adjust pixel values to; IFuII data type range ;I

oK Cancel Help Apply

This block adjusts the contrast of the image by linearly scaling the pixel
values between user-specified upper and lower limits.

6 Use the Histogram Equalization block to modify the contrast in tire.tif.
Accept the default parameters.




Adjust the Contrast of Intensity Images

E! Function Block Parameters: Histogram Equalization x|

—Histogram Equalization {mask) {Jink)

Ernhance the contrast of input image using histogram equalization.

—Parameters

Target histogram: |Uniform ;I

Mumber of bins:

04

oK Cancel Help Apply

This block enhances the contrast of images by transforming the values in
an intensity image so that the histogram of the output image approximately
matches a specified histogram.

7 Use the Video Viewer blocks to view the original and modified images.
Accept the default parameters.

8 Connect the blocks as shown in the following figure.
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9 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time = 0
® Solver pane, Type = Fixed-step
¢ Solver pane, Solver = Discrete (no continuous states)

10 Run the model.

The results appear in the Video Viewer windows.
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In this example, you used the Contrast Adjustment block to linearly scale the
pixel values in pout.tif between new upper and lower limits. You used the
Histogram Equalization block to transform the values in tire.tif so that the
histogram of the output image approximately matches a uniform histogram.
For more information, see the Contrast Adjustment and Histogram
Equalization reference pages.
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Adjust the Contrast of Color Images

This example shows you how to modify the contrast in color images using
the Histogram Equalization block.

1 Use the following code to read in an indexed RGB image, shadow.tif, and
convert it to an RGB image.

[X map] = imread('shadow.tif');
shadow = ind2rgb(X,map);

2 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity

Image From Computer Vision System Toolbox > 1

Workspace Sources

Color Space Computer Vision System Toolbox > 2

Conversion Conversions

Histogram Computer Vision System Toolbox > 1

Equalization Analysis & Enhancement

Video Viewer Computer Vision System Toolbox > 2
Sinks

Constant Simulink > Sources 1

Divide Simulink > Math Operations 1

Product Simulink > Math Operations 1

3 Place the blocks so that your model resembles the following figure.
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4 Use the Image From Workspace block to import the RGB image from the

MATLAB workspace into the Simulink model. Set the block parameters as
follows:

e Value = shadow

¢ Image signal = Separate color signals

5 Use the Color Space Conversion block to separate the luma information

from the color information. Set the block parameters as follows:
® Conversion =sR'G'B' to L*a*b*

¢ Image signal = Separate color signals

Because the range of the L* values is between 0 and 100, you must
normalize them to be between zero and one before you pass them to the
Histogram Equalization block, which expects floating point input in this
range.

6 Use the Constant block to define a normalization factor. Set the Constant
value parameter to 100.

7 Use the Divide block to normalize the L* values to be between 0 and 1.
Accept the default parameters.
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8 Use the Histogram Equalization block to modify the contrast in the image.
Accept the default parameters.

=] Function Block Parameters: Histogram Equalizatio x|

—Hiztogram E qualization [mazk] [link]

Enhance the contrazt of input image wsing histogram equalization.

—Parameterz

Target istogram -

Murnber af bins:
B4

k. Cancel Help Apply

This block enhances the contrast of images by transforming the luma
values in the color image so that the histogram of the output image
approximately matches a specified histogram.

9 Use the Product block to scale the values back to be between the 0 to 100
range. Accept the default parameters.

10 Use the Color Space Conversionl block to convert the values back to the
sR’G’B’ color space. Set the block parameters as follows:

¢ Conversion = L*a*b* to sR'G'B'
¢ Image signal = Separate color signals

11 Use the Video Viewer blocks to view the original and modified images. For
each block, set the Image signal parameter to Separate color signals
from the file menu.

12 Connect the blocks as shown in the following figure.
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13 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

¢ Solver pane, Stop time =0
¢ Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

14 Run the model.
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As shown in the following figure, the model displays the original image in
the Video Viewerl window.
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As the next figure shows, the model displays the enhanced contrast image
in the Video Viewer window.

_inix
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In this example, you used the Histogram Equalization block to transform
the values in a color image so that the histogram of the output image
approximately matches a uniform histogram. For more information, see the
Histogram Equalization reference page.
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Remove Periodic Noise from a Video

Periodic noise can be introduced into a video stream during acquisition or
transmission due to electrical or electromechanical interference. In this
example, you remove periodic noise from an intensity video using the 2-D FIR
Filter block. You can use this technique to remove noise from other images or
video streams, but you might need to modify the filter coefficients to account
for the noise frequency content present in your signal:

1 Create a Simulink model, and add the blocks shown in the following table.

Block Library Quantity
Read Binary File Computer Vision System Toolbox > 1
Sources
Image Data Type Computer Vision System Toolbox > 1
Conversion Conversions
2-D FIR Filter Computer Vision System Toolbox > 1
Filtering
Video Viewer Computer Vision System Toolbox > 3
Sinks
Add Simulink > Math Operations 1

2 Open the Periodic noise reduction demo by typing vipstripes at the
MATLAB command prompt.

3 Click-and-drag the Periodic Noise block into your model.

The block outputs a sinusoid with a normalized frequency that ranges
between 0.61m and 0.69m radians per sample and a phase that varies
between zero and three radians. You are using this sinusoid to represent
periodic noise.

4 Place the blocks so that your model resembles the following figure. The
unconnected ports disappear when you set block parameters.
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You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

Use the Read Binary File block to import a binary file into the model. Set
the block parameters as follows:

* File name = cat_video.bin
* Four character code = GREY

¢ Number of times to play file = inf

Sample time = 1/30
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=] source Block Parameters: Read Binary File x|

—Read Binary File

Read binary video data from file in the specified format.

—Parameters
Filename: Iu:at_\;iu:leu:u.l:uinl Browse. ., |
Video format: IF:::ur character codes ;I
Four character code: IIGF'\Eﬁr ;I
Frame size Rows: |12IZI Cals: IlEuIZI
Line ordering: |T|:||:| line first ;I

Mumber of times to play file: |inf

[T output end-of-file indicator

Sample time: I 1430

QK Cancel Help

6 Use the Image Data Type Conversion block to convert the data type of the
video to single-precision floating point. Accept the default parameter.

7 Use the Video Viewer block to view the original video. Accept the default
parameters.

8 Use the Add block to add the noise video to the original video. Accept the
default parameters.

9 Use the Video Viewerl block to view the noisy video. Accept the default
parameters.

10 Define the filter coefficients in the MATLAB workspace. Type the following
code at the MATLAB command prompt:



Remove Periodic Noise from a Video

vipdh_stripes

The variable h, as well as several others, are loaded into the MATLAB
workspace. The variable h represents the coefficients of the band reject
filter capable of removing normalized frequencies between 0.61m and 0.69m
radians per sample. The coefficients were created using the Filter Design
and Analysis Tool (FDATool) and the ftrans2 function.

Use the 2-D FIR Filter block to model a band-reject filter capable of
removing the periodic noise from the video. Set the block parameters as
follows:

® Coefficients = h

¢ Output size = Same as input port I

* Padding options = Circular

Choose a type of padding that minimizes the effect of the pixels outside the
image on the processing of the image. In this example, circular padding

produces the best results because it is most effective at replicating the
sinusoidal noise outside the image.
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=] Function Block Parameters: 2-D FIR Filter x|
— 2-D FIR Filter

Performs two-dimensional FIR filtering of input matrix I using filter coefficdent matrix H.

‘fou can use the Filtering based on parameter to specify whether your filtering is based on convolution or
correlation.

Use the Output size parameter to specify the dimensions of the output. Assume that the input at port I has
dimensions (Mi, Ni} and the input at port H has dimensions (Mh, Mh). If you choose Full, the output has
dimensions (Mi+Mh-1, Mi-+Mh-1). If you choose Same as input port I, the output has the same dimensions as
the input at port I. If you choose Valid, the block filters the input image only where the coefficient matrix fits
entirely within it, so no padding is required. The output has dimensions (Mi-Mh+1, MitMh+1).

Main | Fixed-pointl

—Parameters

[~ separable filter coefficients

Coefficent source: ISpecify via dialog LI

Coefficients: I h

Qutput size: ISame as input port I

Padding options: ICircuIar

Filtering based on: IConvoluﬁon

Ll L Led

[o]'4 I Cancel | Help | Apply I

12 Use the Video Viewer2 block to view the approximation of the original
video. Accept the default parameters.

13 Connect the block as shown in the following figure.
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14 Set the configuration parameters. Open the Configuration dialog box by

selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time = inf

¢ Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

15 Run the model.
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The noisy video appears in the Video Viewerl window. The following video
is shown at its true size.
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The approximation of the original video appears in the Video Viewer2
window, and the artifacts of the processing appear near the edges of the
video. The following video is shown at its true size.
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You have used the Read Binary File block to import a binary video into your
model, the 2-D FIR Filter to remove periodic noise from this video, and the
Video Viewer block to display the results. For more information about these
blocks, see the Read Binary File, 2-D FIR Filter, and Video Viewer block
reference pages. For more information about the Filter Design and Analysis
Tool (FDATool), see the Signal Processing Toolbox documentation. For
information about the ftrans2 function, see the Image Processing Toolbox
documentation.



Remove Salt and Pepper Noise from Images

Remove Salt and Pepper Noise from Images

Median filtering is a common image enhancement technique for removing
salt and pepper noise. Because this filtering is less sensitive than linear
techniques to extreme changes in pixel values, it can remove salt and pepper
noise without significantly reducing the sharpness of an image. In this topic,
you use the Median Filter block to remove salt and pepper noise from an
intensity image:

1 Define an intensity image in the MATLAB workspace and add noise to it by
typing the following at the MATLAB command prompt:

I= double(imread('circles.png'));
I= imnoise(I, 'salt & pepper',0.02);

I is a 256-by-256 matrix of 8-bit unsigned integer values.

2 To view the image this matrix represents, at the MATLAB command
prompt, type

imshow(I)
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The intensity image contains noise that you want your model to eliminate.

3 Create a Simulink model, and add the blocks shown in the following table.

Block Library Quantity

Image From Computer Vision System Toolbox > 1

Workspace Sources

Median Filter Computer Vision System Toolbox > 1
Filtering

Video Viewer Computer Vision System Toolbox > 2

Sinks

4 Position the blocks as shown in the following figure.
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5 Use the Image From Workspace block to import the noisy image into your
model. Set the Value parameter to I.

6 Use the Median Filter block to eliminate the black and white speckles in
the image. Use the default parameters.
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=] Function Block Parameters: Median Filter x|

—Median Filter

Performs Median filtering of input matrix 1.

Lise the Meighborhood size parameter to spedfy the size of the neighborhood over
which the block computes the median.

LUse the Output size parameter to specify the dimensions of the output. If vou select
Same as input port I, the block outputs an intensity image that is the same size as the
image input to the I port. If you select Valid, the block only computes the median
where the neighborhood fits entirely within the input image, so no padding is required.

Main Fixed-paint I

—Parameters

Meighborhood size: I [33]

Qutput size: ISamE as input port I

Padding options: ICDnstant

L L L

Pad value source: ISpEl:iﬁf via dialog

Pad value; I 0

Ok Cancel Help | Apply |

The Median Filter block replaces the central value of the 3-by-3
neighborhood with the median value of the neighborhood. This process
removes the noise in the image.

7 Use the Video Viewer blocks to display the original noisy image, and
the modified image. Images are represented by 8-bit unsigned integers.
Therefore, a value of 0 corresponds to black and a value of 255 corresponds
to white. Accept the default parameters.

8 Connect the blocks as shown in the following figure.
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9 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time = 0
® Solver pane, Type = Fixed-step

¢ Solver pane, Solver = Discrete (no continuous states)
10 Run the model.

The original noisy image appears in the Video Viewer window. To view
the image at its true size, right-click the window and select Set Display
To True Size.
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The cleaner image appears in the Video Viewerl window. The following
image is shown at its true size.
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You have used the Median Filter block to remove noise from your image. For
more information about this block, see the Median Filter block reference page

in the Computer Vision System Toolbox Reference.
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Sharpen an Image

To sharpen a color image, you need to make the luma intensity transitions
more acute, while preserving the color information of the image. To do this,
you convert an R’G’B’ image into the Y'CbCr color space and apply a highpass
filter to the luma portion of the image only. Then, you transform the image
back to the R'G’B’ color space to view the results. To blur an image, you apply
a lowpass filter to the luma portion of the image. This example shows how

to use the 2-D FIR Filter block to sharpen an image. The prime notation
indicates that the signals are gamma corrected.

1 Define an R°"G’'B’ image in the MATLAB workspace. To read in an R'G'B’
image from a PNG file and cast it to the double-precision data type, at the
MATLAB command prompt, type

I= im2double(imread( 'peppers.png'));

I is a 384-by-512-by-3 array of double-precision floating-point values.
Each plane of this array represents the red, green, or blue color values
of the image.

2 To view the image this array represents, at the MATLAB command
prompt, type

imshow(I)
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2 Figure 1
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Now that you have defined your image, you can create your model.

3 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity

Image From Computer Vision System Toolbox > 1

Workspace Sources

Color Space Computer Vision System Toolbox > 2

Conversion Conversions

2-D FIR Filter Computer Vision System Toolbox > 1
Filtering

Video Viewer Computer Vision System Toolbox > Sinks | 1
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4 Position the blocks as shown in the following figure.
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5 Use the Image From Workspace block to import the R°G'B’ image from the
MATLAB workspace. Set the parameters as follows:

® Main pane, Value = 1

® Main pane, Image signal = Separate color signals

The block outputs the R’, G, and B’ planes of the I array at the output ports.
6 The first Color Space Conversion block converts color information from

the R’G’B’ color space to the Y'CbCr color space. Set the Image signal
parameter to Separate color signals



Sharpen an Image

=] Function Block Parameters: Color Space Conversionl x|

—Color Space Conversion (mask) {ink)

Converts color information between color spaces,

Use the Conversion parameter to specify the color spaces you are converting
between. Your choices are R'G'B' to Y'CbCr, ¥'CbCr to R'GE', R'G'E' to intensity,
R'GE' to HSV, H5V to R'G'E', sR'G'E' to X¥Z, XYZ to sR'GE', sR'GE' to L*a*b™, and
L*a*b™ to sR'G'B".

All conversions support double-precision floating-point and single-precision floating-
point inputs, The conversions from R'G'E' to intensity and between the R'G'B' and
¥'CbCr color spaces also suppart 3-bit unsigned integer inputs,

—Parameters

Conversion: IR'G'B' to Y'ChCr

=l
|se conversion specified by: |Rec. 601 (S0TY) ;I
=l

Image signal: ISEparatE color signals

K Cancel Help | Apply

7 Use the 2-D FIR Filter block to filter the luma portion of the image. Set the
block parameters as follows:

e Coefficients = fspecial('unsharp')
® Output size = Same as input port I
¢ Padding options = Symmetric

¢ Filtering based on = Correlation
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E Function Block Parameters: 2-D FIR Filter

— 2-D FIR Filter

Performs two-dimensional FIR filtering of input matrix I using filter coeffident matrix H.

Yfou can use the Filtering based on parameter to spedfy whether your filtering is based on convolution or
correlation,

|Jse the Qutput size parameter to specify the dimensions of the output, Assume that the input at port I has
dimensions (Mi, Mi) and the input at port H has dimensions (Mh, Nh). If you choose Full, the output has
dimensions (Mi+Mh-1, Mi+Mh-1). If you choose Same as input port I, the output has the same dimensions as
the input at port I. If you choose Valid, the block filters the input image only where the coefficient matrix fits
entirely within it, so no padding is required. The output has dimensions (Mi-Mh+1, MNi-Mh+1).

Main | Fixed-pnintl

—Parameters

[ Separable filter coefficients

Coefficient source: ISpecify via dialog LI

Coefficents: Ifspecial(‘unsharp'}

Quiput size: ISame as input port I

Padding options: ISymmetric

Ll Lef Lo

Filtering based on: ICDrreIah’on

QK I Cancel Help Apply

The fspecial('unsharp') command creates two-dimensional highpass
filter coefficients suitable for correlation. This highpass filter sharpens the
image by removing the low frequency noise in it.

The second Color Space Conversion block converts the color information
from the Y'CbCr color space to the R'G’B’ color space. Set the block
parameters as follows:

e Conversion=Y'CbCr to R'G'B"

e Image signal = Separate color signals



Sharpen an Image

=] Function Block Parameters: Color Space Conversion x|

—Color Space Conversion (mask) {ink)

Converts color information between color spaces,

Use the Conversion parameter to specify the color spaces you are converting
between. Your choices are R'G'B' to Y'CbCr, ¥'CbCr to R'GE', R'G'E' to intensity,
R'GE' to HSV, H5V to R'G'E', sR'G'E' to X¥Z, XYZ to sR'GE', sR'GE' to L*a*b™, and
L*a*b™ to sR'G'B".

All conversions support double-precision floating-point and single-precision floating-
point inputs, The conversions from R'G'E' to intensity and between the R'G'B' and
¥'CbCr color spaces also suppart 3-bit unsigned integer inputs,

—Parameters

Conversion: IY'ChCr to R'GE'

=l
|se conversion specified by: |Rec. 601 (S0TY) ;I
=l

Image signal: ISEparatE color signals

K Cancel Help | Apply

9 Use the Video Viewer block to automatically display the new, sharper
image in the Video Viewer window when you run the model. Set the Image
signal parameter to Separate color signals, by selecting File > Image
Signal.

10 Connect the blocks as shown in the following figure.
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11 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time = 0
® Solver pane, Type = Fixed-step
¢ Solver pane, Solver = Discrete (no continuous states)

12 Run the model.

A sharper version of the original image appears in the Video Viewer
window.
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To blur the image, double-click the 2-D FIR Filter block. Set Coefficients
parameter to fspecial('gaussian',[15 15],7) and then click OK. The
fspecial('gaussian',[15 15],7) command creates two-dimensional
Gaussian lowpass filter coefficients. This lowpass filter blurs the image by
removing the high frequency noise in it.
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In this example, you used the Color Space Conversion and 2-D FIR Filter
blocks to sharpen an image. For more information, see the Color Space
Conversion and 2-D FIR Filter, and fspecial reference pages.
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Statistics and
Morphological Operations

* “Find the Histogram of an Image” on page 7-2
e “Correct Nonuniform Illumination” on page 7-9

e “Count Objects in an Image” on page 7-17
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7-2

Find the Histogram of an Image

The Histogram block computes the frequency distribution of the elements in
each input image by sorting the elements into a specified number of discrete
bins. You can use the Histogram block to calculate the histogram of the R,

G, and/or B values in an image. This example shows you how to accomplish

this task:

1 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity
Image From File Computer Vision System Toolbox > 1
Sources
Video Viewer Computer Vision System Toolbox > 1
Sinks
Matrix Simulink > Math Operations 1
Concatenate
Vector Scope DSP System Toolbox > Signal 1
Processing Sinks
Histogram DSP System Toolbox > Statistics 3

2 Place the blocks so that your model resembles the following figure.
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3 Use the Image From File block to import an RGB image. Set the block

parameters as follows:

¢ Sample time = inf

¢ Image signal = Separate color signals
¢ Output port labels: =R|G|B

¢ Output data type: = double
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4 Use the Video Viewer block to automatically display the original image
in the viewer window when you run the model. Set the Image signal
parameter to Separate color signals.

_loix

File Tools WView Flaybadt Help w
v Open at Start of Simulation I': - |
£ et omersrsi sl

Configuration b Separate Color Signals

Export to Image Tool CimiHE

Close Ctrl-+w
Close All Video Viewer Windows

(No data i1s available until
the gimulation starts. )

Ready

5 Use the Histogram blocks to calculate the histogram of the R, G, and B
values in the image. Set the Main tab block parameters for the three
Histogram blocks as follows:

¢ Lower limit of histogram: 0
¢ Upper limit of histogram: 1
¢ Number of bins: = 256
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x

Histogram
Histogram of the vector elements. If running histogram is selected, block returns the
histogram of the input elements aver time.

Mairi | Data Types I

—Parameters

Lower limit of histogram: I 0

Upper limit of histogram: I 1

Mumber of bins: I 256

[ Mormalized

[ Running histogram

J— oK I Cancel Help Apply

The R, G, and B input values to the Histogram block are double-precision
floating point and range between 0 and 1. The block creates 256 bins
between the maximum and minimum input values and counts the number
of R, G, and B values in each bin.

6 Use the Matrix Concatenate block to concatenate the R, G, and B column
vectors into a single matrix so they can be displayed using the Vector Scope
block. Set the Number of inputs parameter to 3.

7 Use the Vector Scope block to display the histograms of the R, G, and B
values of the input image. Set the block parameters as follows:

®* Scope Properties pane, Input domain = User-defined

¢ Display Properties pane, clear the Frame number check box

¢ Display Properties pane, select the Channel legend check box
¢ Display Properties pane, select the Compact display check box
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Axis Properties pane, clear the Inherit sample increment from
input check box.

Axis Properties pane, Minimum Y-limit =0
Axis Properties pane, Maximum Y-limit = 1
Axis Properties pane, Y-axis label = Count
Line Properties pane, Line markers = . |s|d

Line Properties pane, Line colors =[1 0 0]|[0 1 0]|[0 O 1]

8 Connect the blocks as shown in the following figure.
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DIE”E%I%EI@@?IS’Q » II1C.C IH:::rmaI j|§
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Concatenate Spope
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Histogram2
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9 Open the Configuration dialog box by selecting Configuration
Parameters from the Simulation menu. Set the parameters as follows:

® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

10 Run the model using either the simulation button, or by selecting
Simulation > Start.

The original image appears in the Video Viewer window.

) Video Viewer
File Tools Wiew Playback Help

B O K& &
C I L =

=10l x|

| 100% Rd

Ready

RGE:364x512  T=10.000

11 Right-click in the Vector Scope window and select Autoscale.
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The scaled histogram of the image appears in the Vector Scope window.

) untitled;Yector Scope =] S
a

—— [CH1

—1—cH?2

+10000 —4—CH3

000

You have now used the Histogram block to calculate the histogram of the R,
G, and B values in an RGB image. For more information about this block, see
the Histogram reference page. To open a demo model that illustrates how to
use this block to calculate the histogram of the R, G, and B values in an RGB
video stream, type viphistogram at the MATLAB command prompt.
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Correct Nonuniform lllumination

Global threshold techniques, which are often the first step in object
measurement, cannot be applied to unevenly illuminated images. To correct
this problem, you can change the lighting conditions and take another picture,
or you can use morphological operators to even out the lighting in the image.
Once you have corrected for nonuniform illumination, you can pick a global
threshold that delineates every object from the background. In this topic, you
use the Opening block to correct for uneven lighting in an intensity image:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity
Image From File Computer Vision System Toolbox > | 1
Sources
Opening Computer Vision System Toolbox > | 1
Morphological Operations
Video Viewer Computer Vision System Toolbox > | 4
Sinks
Constant Simulink > Sources 1
Sum Simulink > Math Operations 2
Data Type Conversion | Simulink > Signal Attributes 1

2 Position the blocks as shown in the following figure.
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Once you have assembled the blocks required to correct for uneven
illumination, you need to set your block parameters. To do this, double-click
the blocks, modify the block parameter values, and click OK.

3 Use the Image From File block to import the intensity image. Set the File
name parameter to rice.png. This image is a 256-by-256 matrix of 8-bit
unsigned integer values.

4 Use the Video Viewer block to view the original image. Accept the default
parameters.

5 Use the Opening block to estimate the background of the image.
Set the Neighborhood or structuring element parameter to
strel('disk',15).



Correct Nonuniform lllumination

] Function Block Parameters: Dpening |

—Opening [mazk] [link]

Perform morphological opening on an inkenzity or binary image.

|Jze the Heighborhood or structuning element parameter to define the neighborhood
or ghructuring element that the block applies to the image. Specify a neighborhood by
entering a matrix or wector of ones and zerog. Specify a structuning element uzing the
strel function. Altematively, you can specify neighborhood values uging the Mhood
part.

Faor further information on structuring elements, tppe doc strel at the MATLAB
command prompt,

—Parameters

MHeighborhood or structuing element source: | Specify via dialog ;I

Meighborhood ar structuring element:
|strell'dizk’ 15)

Apply

ak I Cancel

The strel function creates a circular STREL object with a radius of 15
pixels. When working with the Opening block, pick a STREL object that
fits within the objects you want to keep. It often takes experimentation to
find the neighborhood or STREL object that best suits your application.

6 Use the Video Viewerl block to view the background estimated by the
Opening block. Accept the default parameters.

7 Use the first Sum block to subtract the estimated background from the
original image. Set the block parameters as follows:

¢ Icon shape = rectangular

¢ List of signs = -+

8 Use the Video Viewer2 block to view the result of subtracting the
background from the original image. Accept the default parameters.

9 Use the Constant block to define an offset value. Set the Constant value
parameter to 80.

10 Use the Data Type Conversion block to convert the offset value to an 8-bit
unsigned integer. Set the Output data type mode parameter to uints.
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11 Use the second Sum block to lighten the image so that it has the same
brightness as the original image. Set the block parameters as follows:

® Icon shape = rectangular
® List of signs = ++

12 Use the Video Viewer3 block to view the corrected image. Accept the
default parameters.

13 Connect the blocks as shown in the following figure.

File Edit View Simulation Format Tools Help
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Ready
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14 Set the configuration parameters. Open the Configuration dialog box by

selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
¢ Solver pane, Type = Fixed-step

® Solver pane, Solver = discrete (no continuous states)
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15 Run the model.

The original image appears in the Video Viewer window.

=

File Tools View Playback Help N

B OB ® & &Y 0% ~]

Ready [ 256256 T=0.000

The estimated background appears in the Video Viewerl window.
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File Tools View Playback Help u
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Ready |: 256256 T=0.000

The image without the estimated background appears in the Video Viewer2
window.
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_loix
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The preceding image is too dark. The Constant block provides an offset
value that you used to brighten the image.

The corrected image, which has even lighting, appears in the Video Viewer3
window. The following image is shown at its true size.
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In this section, you have used the Opening block to remove irregular
illumination from an image. For more information about this block, see
the Opening reference page. For related information, see the Top-hat block
reference page. For more information about STREL objects, see the strel
function in the Image Processing Toolbox documentation.
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Count Objects in an Image

In this example, you import an intensity image of a wheel from the MATLAB
workspace and convert it to binary. Then, using the Opening and Label blocks,
you count the number of spokes in the wheel. You can use similar techniques
to count objects in other intensity images. However, you might need to use
additional morphological operators and different structuring elements:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

Image From File Computer Vision System Toolbox > | 1
Sources

Opening Computer Vision System Toolbox> | 1
Morphological Operations

Label Computer Vision System Toolbox > | 1
Morphological Operations

Video Viewer Computer Vision System Toolbox > | 2
Sinks

Constant Simulink > Sources 1

Relational Operator Simulink > Logic and Bit 1
Operations

Display DSP System Toolbox > Signal 1

Processing Sinks

2 Position the blocks as shown in the following figure. The unconnected ports
disappear when you set block parameters.
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You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

3 Use the Image From File block to import your image. Set the File name
parameter to testpati.png. This is a 256-by-256 matrix image of 8-bit
unsigned integers.

4 Use the Constant block to define a threshold value for the Relational
Operator block. Set the Constant value parameter to 200.

5 Use the Video Viewer block to view the original image. Accept the default
parameters.

6 Use the Relational Operator block to perform a thresholding operation
that converts your intensity image to a binary image. Set the Relational
Operator parameter to <.

If the input to the Relational Operator block is less than 200, its output is
1; otherwise, its output is 0. You must threshold your intensity image
because the Label block expects binary input. Also, the objects it counts
must be white.

7 Use the Opening block to separate the spokes from the rim and from each
other at the center of the wheel. Use the default parameters.
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] Function Block Parameters: Dpening |

—Opening [mazk] [link]

Perform morphological opening on an inkenzity or binary image.

|Jze the Heighborhood or structuning element parameter to define the neighborhood
or ghructuring element that the block applies to the image. Specify a neighborhood by
entering a matrix or wector of ones and zerog. Specify a structuning element uzing the
strel function. Altematively, you can specify neighborhood values uging the Mhood
part.

Faor further information on structuring elements, tppe doc strel at the MATLAB
command prompt,

—Parameters

MHeighborhood or structuing element source: | Specify via dialog ;I

Meighborhood ar structuring element:
|strell'dizk 5]

Cancel Help Apply

The strel function creates a circular STREL object with a radius of 5
pixels. When working with the Opening block, pick a STREL object that
fits within the objects you want to keep. It often takes experimentation to
find the neighborhood or STREL object that best suits your application.

8 Use the Video Viewerl block to view the opened image. Accept the default
parameters.

9 Use the Label block to count the number of spokes in the input image. Set
the Output parameter to Number of labels.
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E Function Block Parameters: Label x|

—Label [mazk] [link]

Labelz and counts connected components in a binary image.

At the Label port, the block outputs a label matriz where pixel: equal to O represent
the backaground, piels equal to 1 represent the first object, pixels equal to 2 represent
the second object, and zo0 on. At the Count part, block outputs a scalar that
represents the number of labeled objects.

|Jze the Connectivity parameter ta define which pisels are connected to each ather.

—Parameters
Connectivity: I g ;I
Elutput:l Mumber of labels ;I
Output data tppe; I Automatic ;I

ak I Cancel

Apply |

10 The Display block displays the number of spokes in the input image. Use
the default parameters.

11 Connect the block as shown in the following figure.
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12 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set

the parameters as follows:

® Solver pane, Stop time =0

® Solver pane, Type = Fixed-step

® Solver pane, Solver = discrete (no continuous states)

13 Run the model.

The original image appears in the Video Viewerl window. To view the
image at its true size, right-click the window and select Set Display To

True Size.
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The opened image appears in the Video Viewer window. The following
image is shown at its true size.
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As you can see in the preceding figure, the spokes are now separate white
objects. In the model, the Display block correctly indicates that there are
24 distinct spokes.
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You have used the Opening and Label blocks to count the number of spokes
in an image. For more information about these blocks, see the Opening and
Label block reference pages in the Computer Vision System Toolbox Reference.
If you want to send the number of spokes to the MATLAB workspace, use the
To Workspace block in Simulink or the Signal to Workspace block in DSP
System Toolbox. For more information about STREL objects, see strel in the
Image Processing Toolbox documentation.

7-23



7 Statistics and Morphological Operations

7-24



Code Generation

® “System Objects that Generate Code” on page 8-2
¢ “Functions that Generate Code” on page 8-6
e “Shared Library Dependencies” on page 8-7
e “Accelerating Simulink Models” on page 8-8
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System Objects that Generate Code

The following Computer Vision System Toolbox System objects support code
generation in MATLAB. See “Use System Objects for Code Generation from
MATLAB” and “Use System Objects for Code Generation from MATLAB”.

Supported Computer Vision System Toolbox System Objects

Object

Description

Analysis & Enhancement

vision.BoundaryTracer

Trace object boundaries in binary images

vision.ContrastAdjuster

Adjust image contrast by linear scaling

vision.Deinterlacer

Remove motion artifacts by deinterlacing input
video signal

vision.EdgeDetector

Find edges of objects in images

vision.ForegroundDetector

Detect foreground using Gaussian Mixture
Models

vision.HistogramEqualizer

Enhance contrast of images using histogram
equalization

vision.TemplateMatcher

Perform template matching by shifting
template over image

Conversions

vision.Autothresholder

Convert intensity image to binary image

vision.ChromaResampler

Downsample or upsample chrominance
components of images

vision.ColorSpaceConverter

Convert color information between color spaces

vision.DemosaicInterpolator

Demosaic Bayer’s format images

vision.GammaCorrector

Apply or remove gamma correction from
images or video streams

vision.ImageComplementer

Compute complement of pixel values in binary,
intensity, or RGB images
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Supported Computer Vision System Toolbox System Objects (Continued)

Object Description

vision.ImageDataTypeConverter Convert and scale input image to specified
output data type

Filtering

vision.Convolver Compute 2-D discrete convolution of two input
matrices

vision.ImageFilter Perform 2-D FIR filtering of input matrix

vision.MedianFilter 2D median filtering

Geometric Transformations

vision.GeometricRotator Rotate image by specified angle

vision.GeometricRotator Enlarge or shrink image size

vision.GeometricScaler Shift rows or columns of image by linearly

varying offset

vision.GeometricTransformer Apply projective or affine transformation to an
image
vision.GeometricTransformEstimator Estimate geometric transformation from

matching point pairs

vision.GeometricTranslator Translate image in two-dimensional plane
using displacement vector

Morphological Operations

vision.ConnectedComponentLabeler Label and count the connected regions in a
binary image

vision.MorphologicalClose Perform morphological closing on image

vision.MorphologicalDilate Perform morphological dilation on an image

vision.MorphologicalErode Perform morphological erosion on an image
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Supported Computer Vision System Toolbox System Objects (Continued)

Object

Description

vision.MorphologicalOpen

Perform morphological opening on an image

Sinks

vision.DeployableVideoPlayer

Send video data to computer screen

vision.VideoFileWriter

Write video frames and audio samples to
multimedia file

Sources

vision.VideoFileReader

Read video frames and audio samples from
compressed multimedia file

Statistics

vision.Autocorrelator

Compute 2-D autocorrelation of input matrix

vision.BlobAnalysis

Compute statistics for connected regions in a
binary image

vision.Crosscorrelator

Compute 2-D cross-correlation of two input
matrices

vision.Histogram

Generate histogram of each input matrix

vision.LocalMaximaFinder

Find local maxima in matrices

vision.Maximum

Find maximum values in input or sequence of
inputs

vision.Mean

Find mean value of input or sequence of inputs

vision.Median

Find median values in an input

vision.Minimum

Find minimum values in input or sequence of
inputs

vision.PSNR

Compute peak signal-to-noise ratio (PSNR)
between images
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Supported Computer Vision System Toolbox System Objects (Continued)

Object

Description

vision.StandardDeviation

Find standard deviation of input or sequence
of inputs

vision.Variance

Find variance values in an input or sequence
of inputs

Text & Graphics

vision.AlphaBlender

Combine images, overlay images, or highlight
selected pixels

vision.MarkerInserter

Draw markers on output image

vision.ShapeInserter

Draw rectangles, lines, polygons, or circles on
1images

vision.TextInserter

Draw text on image or video stream

Transforms
vision.DCT Compute 2-D discrete cosine transform
vision.FFT Two-dimensional discrete Fourier transform

vision.HoughLines

Find Cartesian coordinates of lines that are
described by rho and theta pairs

vision.HoughTransform

Find lines in images via Hough transform

vision.IDCT

Compute 2-D inverse discrete cosine transform

vision.Pyramid

Perform Gaussian pyramid decomposition
Back to Top of Page Back to Top

Utilities

vision.ImagePadder

Pad or crop input image along its rows,
columns, or both
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Functions that Generate Code

The following Computer Vision System Toolbox functions support code
generation in MATLAB. See “Use System Objects for Code Generation from
MATLAB” for more information.

Function Description

epipolarLine Compute epipolar lines for stereo images

estimateFundamentalMatrix | Estimate fundamental matrix from corresponding points in
stereo image

estimateUncalibratedRectifilchihicdibrated stereo rectification

extractFeatures Extract interest point descriptors

isEpipoleInImage Determine whether image contains epipole
lineToBorderPoints Intersection points of lines in image and image border
matchFeatures Find matching image features
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Shared Library Dependencies

In general, the code you generate from Computer Vision System Toolbox
blocks is portable ANSI® C code. After you generate the code, you can
deploy it on another machine. For more information on how to do so, see
“Relocating Code to Another Development Environment” in the Simulink
Coder documentation.

There are a few Computer Vision System Toolbox blocks that generate code
with limited portability. These blocks use precompiled shared libraries, such
as DLLs, to support I/O for specific types of devices and file formats. To
find out which blocks use precompiled shared libraries, open the Computer
Vision System Toolbox Block Support Table. You can identify blocks that
use precompiled shared libraries by checking the footnotes listed in the
Code Generation Support column of the table. All blocks that use shared
libraries have the following footnote:

Host computer only. Excludes Real-Time Windows (RTWIN) target.

Simulink Coder provides functions to help you set up and manage the build
information for your models. For example, one of the “Build Information ”
functions that Simulink Coder provides is getNonBuildFiles. This function
allows you to identify the shared libraries required by blocks in your model. If
your model contains any blocks that use precompiled shared libraries, you can
install those libraries on the target system. The folder that you install the
shared libraries in must be on the system path. The target system does not
need to have MATLAB installed, but it does need to be supported by MATLAB.
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Accelerating Simulink Models

The Simulink software offer Accelerator and Rapid Accelerator simulation
modes that remove much of the computational overhead required by Simulink
models. These modes compile target code of your model. Through this method,
the Simulink environment can achieve substantial performance improvements
for larger models. The performance gains are tied to the size and complexity
of your model. Therefore, large models that contain Computer Vision System
Toolbox blocks run faster in Rapid Accelerator or Accelerator mode.

To change between Rapid Accelerator, Accelerator, and Normal mode, use
the drop-down list at the top of the model window.

E!vipstahilize_win ;lglil

File Edit Wiew Simulakion  Format  Tools  Help
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shaky_car. avi Target | Template
W 240320, | ] Sowrce
30 fps Stabilized o] Stabilized
From Multimedia File
= Original
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FractEstim Results
TlipBarder p| 332854
Frame Rate
(D Edit
Parameters

For more information on the accelerator modes in Simulink, see “Accelerating
Models” in the Simulink User’s Guide.
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